Browse Source

Merge pull request #1228 from dangowrt/fix-cryptodev-on-kernel-4

cryptodev: get rid of get_unused_fd()
Nikos Mavrogiannopoulos 9 years ago
parent
commit
73f22e9c69

+ 1
- 1
utils/cryptodev-linux/Makefile View File

@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
11 11
 
12 12
 PKG_NAME:=cryptodev-linux
13 13
 PKG_VERSION:=1.7
14
-PKG_RELEASE:=1
14
+PKG_RELEASE:=2
15 15
 
16 16
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
17 17
 PKG_SOURCE_URL:=http://download.gna.org/cryptodev-linux/

+ 13
- 0
utils/cryptodev-linux/patches/001-no-get-unused-fd.patch View File

@@ -0,0 +1,13 @@
1
+Index: cryptodev-linux-1.7/ioctl.c
2
+===================================================================
3
+--- cryptodev-linux-1.7.orig/ioctl.c
4
++++ cryptodev-linux-1.7/ioctl.c
5
+@@ -546,7 +546,7 @@ static int
6
+ clonefd(struct file *filp)
7
+ {
8
+ 	int ret;
9
+-	ret = get_unused_fd();
10
++	ret = get_unused_fd_flags(0);
11
+ 	if (ret >= 0) {
12
+ 			get_file(filp);
13
+ 			fd_install(ret, filp);