Quellcode durchsuchen

ortp: moved to telephony feed

Signed-off-by: Nicolas Thill <nico@openwrt.org>
Nicolas Thill vor 10 Jahren
Ursprung
Commit
7461d7f44a
1 geänderte Dateien mit 0 neuen und 79 gelöschten Zeilen
  1. 0
    79
      libs/ortp/Makefile

+ 0
- 79
libs/ortp/Makefile Datei anzeigen

@@ -1,79 +0,0 @@
1
-#
2
-# Copyright (C) 2010-2015 OpenWrt.org
3
-#
4
-# This is free software, licensed under the GNU General Public License v2.
5
-# See /LICENSE for more information.
6
-#
7
-
8
-include $(TOPDIR)/rules.mk
9
-
10
-PKG_NAME:=ortp
11
-PKG_VERSION:=0.23.0
12
-PKG_RELEASE:=1
13
-
14
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
-PKG_SOURCE_URL:=@SAVANNAH/linphone/ortp/sources
16
-PKG_MD5SUM:=fb833cc7a66ec1a0c1b75016130e7e6d
17
-
18
-PKG_LICENSE:=LGPL-2.1
19
-PKG_LICENSE_FILES:=COPYING
20
-PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
21
-
22
-PKG_INSTALL:=1
23
-
24
-include $(INCLUDE_DIR)/package.mk
25
-
26
-define Package/libortp
27
-  SECTION:=libs
28
-  CATEGORY:=Libraries
29
-  TITLE:=Real-time Transport Protocol (RTP) library
30
-  URL:=http://www.linphone.org/technical-corner/ortp/overview
31
-  DEPENDS:= +libpthread +librt
32
-endef
33
-
34
-ifneq ($(CONFIG_avr32),)
35
-  TARGET_CFLAGS += -fsigned-char
36
-endif
37
-
38
-CONFIGURE_ARGS += \
39
-	--enable-shared \
40
-	--enable-static \
41
-	--disable-debug \
42
-	--enable-ipv6 \
43
-	--enable-perf \
44
-	--disable-ssl-hmac \
45
-	--disable-tests \
46
-	--without-srtp \
47
-
48
-CONFIGURE_VARS += \
49
-	ac_cv_header_srtp_srtp_h=no \
50
-	ac_cv_lib_srtp_srtp_init=no \
51
-	ac_cv_path_DOXYGEN= \
52
-
53
-define Build/InstallDev
54
-	$(INSTALL_DIR) $(1)/usr/include
55
-	( cd $(PKG_INSTALL_DIR); $(CP) \
56
-		./usr/include/ortp \
57
-		$(1)/usr/include/ \
58
-	)
59
-	$(INSTALL_DIR) $(1)/usr/lib
60
-	( cd $(PKG_INSTALL_DIR); $(CP) \
61
-		./usr/lib/libortp.{a,so*} \
62
-		$(1)/usr/lib/ \
63
-	)
64
-	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
65
-	( cd $(PKG_INSTALL_DIR); $(CP) \
66
-		./usr/lib/pkgconfig/ortp.pc \
67
-		$(1)/usr/lib/pkgconfig/ \
68
-	)
69
-endef
70
-
71
-define Package/libortp/install
72
-	$(INSTALL_DIR) $(1)/usr/lib
73
-	( cd $(PKG_INSTALL_DIR); $(CP) \
74
-		./usr/lib/libortp.so.* \
75
-		$(1)/usr/lib/ \
76
-	)
77
-endef
78
-
79
-$(eval $(call BuildPackage,libortp))