浏览代码

gcc: Update GCC Makefile to let it build gcc 4.6 for target.

Signed-off-by: Christian Beier <dontmind@freeshell.org>
Christian Beier 10 年前
父节点
当前提交
758da3487e
共有 1 个文件被更改,包括 20 次插入12 次删除
  1. 20
    12
      devel/gcc/Makefile

+ 20
- 12
devel/gcc/Makefile 查看文件

@@ -4,17 +4,17 @@
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
6 6
 #
7
+#
8
+# NB: GCC building is a bit special, you need to have the gcc build-deps installed on the build machine as well,
9
+#     for instance mpfr, mpc and gmp development packages!
10
+#
7 11
 include $(TOPDIR)/rules.mk
8 12
 PKG_NAME:=gcc
9
-PKG_VERSION:=$(strip $(subst ",, $(CONFIG_GCC_VERSION)))#"))
13
+PKG_VERSION:=linaro-4.6-2013.05
10 14
 PKG_RELEASE:=1
11
-PATCH_DIR=$(TOPDIR)/toolchain/gcc/patches/$(PKG_VERSION)
12
-PKG_SOURCE_URL:=ftp://ftp.fu-berlin.de/unix/languages/gcc/releases/gcc-$(PKG_VERSION) \
13
-    http://mirrors.rcn.net/pub/sourceware/gcc/releases/gcc-$(PKG_VERSION) \
14
-	    ftp://ftp.gnu.org/gnu/gcc/releases/gcc-$(PKG_VERSION)
15
-
16
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
17
-PKG_MD5SUM:=354853e0b2da90c527e35aabb8d6f1e6
15
+PKG_SOURCE_URL:=https://releases.linaro.org/13.05/components/toolchain/gcc-linaro/4.6/
16
+PKG_SOURCE:=gcc-$(PKG_VERSION).tar.bz2
17
+PKG_MD5SUM:=26b48802ae1203cd99415026fbf56ed7
18 18
 
19 19
 include $(INCLUDE_DIR)/package.mk
20 20
 
@@ -34,13 +34,15 @@ define Package/gcc/description
34 34
 endef
35 35
 
36 36
 define Build/Prepare
37
-	$(call Build/Prepare/Default)
37
+	$(PKG_UNPACK)
38
+# 	we have to download additional stuff before patching
39
+	(cd $(PKG_BUILD_DIR) && ./contrib/download_prerequisites)
40
+	$(Build/Patch)
38 41
 	$(SED) 's,\(version_string.. = "[0-9\.]*\).*\(";\),\1 (OpenWrt-2.0)\2,' $(PKG_BUILD_DIR)/gcc/version.c
39 42
 	$(SED) 's,\(bug_report_url.. = "\).*\(";\),\1<URL:https://dev.openwrt.org/>\2,' $(PKG_BUILD_DIR)/gcc/version.c
40
-	(cd $(PKG_BUILD_DIR)/libstdc++-v3; autoconf;);
41
-	$(SED) 's,gcc_no_link=yes,gcc_no_link=no,' $(PKG_BUILD_DIR)/libstdc++-v3/configure
42 43
 endef
43 44
 
45
+
44 46
 define Build/Configure
45 47
 	(cd $(PKG_BUILD_DIR); rm -f config.cache; \
46 48
 		SHELL="$(BASH)" \
@@ -51,16 +53,22 @@ define Build/Configure
51 53
 			--host=$(REAL_GNU_TARGET_NAME) \
52 54
 			--target=$(REAL_GNU_TARGET_NAME) \
53 55
 			--enable-languages=$(TARGET_LANGUAGES) \
54
-			--enable-shared \
55 56
 			--disable-__cxa_atexit \
56 57
 			--enable-target-optspace \
57 58
 			--with-gnu-ld \
58 59
 			--disable-nls \
59 60
 			--disable-libmudflap \
60 61
 			--disable-multilib \
62
+			--disable-libgomp \
63
+			--disable-libquadmath \
64
+			--disable-decimal-float \
65
+			--with-host-libstdcxx=-lstdc++ \
66
+			--disable-libstdcxx-pch \
61 67
 			$(EXTRA_TARGET) \
62 68
 			$(SOFT_FLOAT_CONFIG_OPTION) \
63 69
 			$(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
70
+			$(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 \
71
+			--with-abi=$(subst ",,$(CONFIG_MIPS64_ABI))) \
64 72
 	);
65 73
 endef
66 74