Browse Source

squid: fix musl compatibility

Change `sys/signal.h` include to just `signal.h`. The build otherwise fails
due to `-Werror` with the following message:

    In file included from rfcnb-io.c:43:0:
    .../staging_dir/toolchain-mipsel_mips32_gcc-4.8-linaro_musl-1.1.10/include/sys/signal.h:1:2: error: #warning redirecting incorrect #include <sys/signal.h> to <signal.h> [-Werror=cpp]
     #warning redirecting incorrect #include <sys/signal.h> to <signal.h>
      ^
    cc1: all warnings being treated as errors

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Jo-Philipp Wich 9 years ago
parent
commit
768f1a42ae
2 changed files with 16 additions and 1 deletions
  1. 1
    1
      net/squid/Makefile
  2. 15
    0
      net/squid/patches/200-musl-compat.patch

+ 1
- 1
net/squid/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=squid
11 11
 PKG_VERSION:=3.5.2
12
-PKG_RELEASE:=3
12
+PKG_RELEASE:=4
13 13
 
14 14
 PKG_LICENSE:=GPL-2.0
15 15
 PKG_MAINTAINER:=Luka Perkov <luka@openwrt.org>

+ 15
- 0
net/squid/patches/200-musl-compat.patch View File

@@ -0,0 +1,15 @@
1
+--- a/lib/rfcnb/rfcnb-io.c
2
++++ b/lib/rfcnb/rfcnb-io.c
3
+@@ -36,11 +36,11 @@
4
+ #include "rfcnb/rfcnb-util.h"
5
+ #include "rfcnb/std-includes.h"
6
+ 
7
++#include <signal.h>
8
+ #if HAVE_STRING_H
9
+ #include <string.h>
10
+ #endif
11
+ #include <sys/uio.h>
12
+-#include <sys/signal.h>
13
+ 
14
+ int RFCNB_Timeout = 0;          /* Timeout in seconds ... */
15
+