|
@@ -0,0 +1,86 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2006-2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=procps
|
|
11
|
+PKG_VERSION:=3.2.8
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+PKG_LICENSE:=GPL-2.0
|
|
14
|
+PKG_LICENSE_FILES:=COPYING COPYING.LIB
|
|
15
|
+
|
|
16
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
17
|
+PKG_SOURCE_URL:=http://procps.sourceforge.net
|
|
18
|
+PKG_MD5SUM:=9532714b6846013ca9898984ba4cd7e0
|
|
19
|
+
|
|
20
|
+PKG_BUILD_PARALLEL:=1
|
|
21
|
+
|
|
22
|
+include $(INCLUDE_DIR)/package.mk
|
|
23
|
+
|
|
24
|
+PROCPS_APPLETS := \
|
|
25
|
+ ps free pgrep pkill pmap pwdx skill w \
|
|
26
|
+ slabtop snice tload top vmstat watch
|
|
27
|
+
|
|
28
|
+define Package/procps/Default
|
|
29
|
+ SECTION:=utils
|
|
30
|
+ CATEGORY:=Utilities
|
|
31
|
+ DEPENDS:=+libncurses
|
|
32
|
+ TITLE:=proc utilities
|
|
33
|
+ URL:=http://procps.sourceforge.net/
|
|
34
|
+ MAINTAINER:=Gergely Kiss <mail.gery@gmail.com>
|
|
35
|
+endef
|
|
36
|
+
|
|
37
|
+define Package/procps
|
|
38
|
+ $(call Package/procps/Default)
|
|
39
|
+ MENU:=1
|
|
40
|
+endef
|
|
41
|
+
|
|
42
|
+define Package/procps/description
|
|
43
|
+ procps is the package that has a bunch of small useful utilities that give
|
|
44
|
+ information about processes using the /proc filesystem. The package
|
|
45
|
+ includes the programs ps, top, vmstat, w, kill, free, slabtop, and skill.
|
|
46
|
+endef
|
|
47
|
+
|
|
48
|
+define GenPlugin
|
|
49
|
+ define Package/$(1)
|
|
50
|
+ $(call Package/procps/Default)
|
|
51
|
+ DEPENDS:=procps
|
|
52
|
+ TITLE:=Applet $(2) from the procps package
|
|
53
|
+ DEFAULT:=y
|
|
54
|
+ endef
|
|
55
|
+
|
|
56
|
+ define Package/$(1)/description
|
|
57
|
+ Installs the applet $(2).
|
|
58
|
+ endef
|
|
59
|
+endef
|
|
60
|
+
|
|
61
|
+$(foreach a,$(PROCPS_APPLETS),$(eval $(call GenPlugin,procps-$(a),$(a))))
|
|
62
|
+
|
|
63
|
+MAKE_FLAGS += \
|
|
64
|
+ CFLAGS="$(TARGET_CFLAGS)" \
|
|
65
|
+ CPPFLAGS="$(TARGET_CPPFLAGS)" \
|
|
66
|
+ LDFLAGS="$(TARGET_LDFLAGS)" \
|
|
67
|
+
|
|
68
|
+define Package/procps/install
|
|
69
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
70
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
71
|
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/proc/libproc-$(PKG_VERSION).so $(1)/usr/lib/
|
|
72
|
+endef
|
|
73
|
+
|
|
74
|
+AUXDIR_ps := "ps/"
|
|
75
|
+
|
|
76
|
+define BuildPlugin
|
|
77
|
+ define Package/$(1)/install
|
|
78
|
+ $(INSTALL_DIR) $$(1)/usr/bin
|
|
79
|
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(AUXDIR_$(2))$(2) $$(1)/usr/bin/
|
|
80
|
+ endef
|
|
81
|
+
|
|
82
|
+ $$(eval $$(call BuildPackage,$(1)))
|
|
83
|
+endef
|
|
84
|
+
|
|
85
|
+$(foreach a,$(PROCPS_APPLETS),$(eval $(call BuildPlugin,procps-$(a),$(a))))
|
|
86
|
+$(eval $(call BuildPackage,procps))
|