Browse Source

Merge pull request #1722 from rraptorr/bind-ecdsa

bind: Enable ECDSA support
Noah Meyerhans 9 years ago
parent
commit
76ce481cc2
1 changed files with 3 additions and 1 deletions
  1. 3
    1
      net/bind/Makefile

+ 3
- 1
net/bind/Makefile View File

@@ -27,6 +27,8 @@ PKG_REMOVE_FILES:=aclocal.m4 libtool.m4
27 27
 
28 28
 PKG_INSTALL:=1
29 29
 
30
+PKG_CONFIG_DEPENDS := CONFIG_OPENSSL_WITH_EC
31
+
30 32
 include $(INCLUDE_DIR)/package.mk
31 33
 
32 34
 define Package/bind/Default
@@ -100,7 +102,7 @@ CONFIGURE_ARGS += \
100 102
 	--enable-epoll=yes \
101 103
 	--with-gost=no \
102 104
 	--with-gssapi=no \
103
-	--with-ecdsa=no \
105
+	--with-ecdsa=$(if $(CONFIG_OPENSSL_WITH_EC),yes,no) \
104 106
 	--with-readline=no
105 107
 
106 108
 CONFIGURE_VARS += \