ソースを参照

pps-tools: update package, allow compiling on more recent kernels

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
Zoltan HERPAI 10 年 前
コミット
76ed6173bf
共有1 個のファイルを変更した50 個の追加0 個の削除を含む
  1. 50
    0
      utils/pps-tools/Makefile

+ 50
- 0
utils/pps-tools/Makefile ファイルの表示

@@ -0,0 +1,50 @@
1
+#
2
+# Copyright (C) 2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=pps-tools
11
+PKG_VERSION:=2014-08-01
12
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
13
+
14
+PKG_SOURCE_PROTO:=git
15
+PKG_SOURCE_URL:=git://github.com/ago/pps-tools
16
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
17
+PKG_SOURCE_VERSION:=0deb9c7e135e9380a6d09e9d2e938a146bb698c8
18
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
19
+
20
+PKG_MAINTAINER := Zoltan HERPAI <wigyori@uid0.hu>
21
+PKG_LICENSE:=GPL-2.0
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+
25
+define Package/pps-tools
26
+  SECTION:=utils
27
+  CATEGORY:=Utilities
28
+  TITLE:=PPS-tools
29
+  DEPENDS:=@LINUX_3_10||@LINUX_3_13||@LINUX_3_14
30
+endef
31
+
32
+define Package/pps-tools/description
33
+  Userland tools for GPS and DCF-77 Clock syncronization. PPS support in Kernel must be enabled.
34
+endef
35
+
36
+TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
37
+
38
+define Build/InstallDev
39
+	$(INSTALL_DIR) $(1)/usr/include
40
+	$(CP) $(PKG_BUILD_DIR)/timepps.h $(1)/usr/include/
41
+endef
42
+
43
+define Package/pps-tools/install
44
+	$(INSTALL_DIR) $(1)/usr/sbin
45
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/ppsctl $(1)/usr/sbin/
46
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/ppstest $(1)/usr/sbin/
47
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/ppswatch $(1)/usr/sbin/
48
+endef
49
+
50
+$(eval $(call BuildPackage,pps-tools))