Przeglądaj źródła

[sqm-scripts/luci-app-sqm] Document how to disable shaping on a per direction basis

sqm-scripts for a long time interprets a "Down- or Upload speed" of zero as
an indication that the shaper should be disabled. Note that really shaping
an individual direction down  o zero will make the link effectively dead
for tcp (think reverse ACK traffic). Son instead of allowing the user to
configure something broken, 0 was "over-loaded" to denote no shaping
since several years, but that information has not been documented visibly
to the users. This commit aims at fixing that oversight.

Signed-off-by: Sebastian Moeller <moeller0@gmx.de>
Toke Høiland-Jørgensen 9 lat temu
rodzic
commit
771ce26a71
2 zmienionych plików z 3 dodań i 3 usunięć
  1. 1
    1
      net/luci-app-sqm/Makefile
  2. 2
    2
      net/luci-app-sqm/files/sqm-cbi.lua

+ 1
- 1
net/luci-app-sqm/Makefile Wyświetl plik

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=luci-app-sqm
11 11
 PKG_VERSION:=3
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 PKG_LICENSE:=GPLv2
14 14
 LUCI_DIR:=/usr/lib/lua/luci
15 15
 

+ 2
- 2
net/luci-app-sqm/files/sqm-cbi.lua Wyświetl plik

@@ -52,11 +52,11 @@ end
52 52
 n.rmempty = false
53 53
 
54 54
 
55
-dl = s:taboption("tab_basic", Value, "download", translate("Download speed (kbit/s) (ingress):"))
55
+dl = s:taboption("tab_basic", Value, "download", translate("Download speed (kbit/s) (ingress) set to 0 to selectively disable ingress shaping:"))
56 56
 dl.datatype = "and(uinteger,min(0))"
57 57
 dl.rmempty = false
58 58
 
59
-ul = s:taboption("tab_basic", Value, "upload", translate("Upload speed (kbit/s) (egress):"))
59
+ul = s:taboption("tab_basic", Value, "upload", translate("Upload speed (kbit/s) (egress) set to 0 to selectively disable egress shaping:"))
60 60
 ul.datatype = "and(uinteger,min(0))"
61 61
 ul.rmempty = false
62 62