|
@@ -0,0 +1,50 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 20013-2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=lua-bencode
|
|
11
|
+PKG_VERSION:=2.1.0
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
15
|
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
|
16
|
+PKG_SOURCE_URL:=https://bitbucket.org/wilhelmy/lua-bencode
|
|
17
|
+PKG_SOURCE_PROTO:=hg
|
|
18
|
+PKG_SOURCE_VERSION:=500243383cb6acbddd3cf12aee6e4667aab53324
|
|
19
|
+PKG_LICENSE:=MIT
|
|
20
|
+
|
|
21
|
+include $(INCLUDE_DIR)/package.mk
|
|
22
|
+
|
|
23
|
+define Package/lua-bencode
|
|
24
|
+ SUBMENU:=Lua
|
|
25
|
+ SECTION:=lang
|
|
26
|
+ CATEGORY:=Languages
|
|
27
|
+ TITLE:=lua-bencode
|
|
28
|
+ URL:=https://bitbucket.org/wilhelmy/lua-bencode
|
|
29
|
+ MAINTAINER:=Lars Gierth <larsg@systemli.org>
|
|
30
|
+ DEPENDS:=+lua
|
|
31
|
+endef
|
|
32
|
+
|
|
33
|
+define Package/lua-bencode/description
|
|
34
|
+ This is a module for the lua programming language for decoding and encoding
|
|
35
|
+ bencoded data which can be used to read and write torrent files for bittorrent.
|
|
36
|
+endef
|
|
37
|
+
|
|
38
|
+define Build/Configure
|
|
39
|
+endef
|
|
40
|
+
|
|
41
|
+define Build/Compile
|
|
42
|
+endef
|
|
43
|
+
|
|
44
|
+
|
|
45
|
+define Package/lua-bencode/install
|
|
46
|
+ $(INSTALL_DIR) $(1)/usr/lib/lua
|
|
47
|
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/bencode.lua $(1)/usr/lib/lua
|
|
48
|
+endef
|
|
49
|
+
|
|
50
|
+$(eval $(call BuildPackage,lua-bencode))
|