Browse Source

knxd: fix musl compatibility

Signed-off-by: Othmar Truniger <github@truniger.ch>
Othmar Truniger 9 years ago
parent
commit
77cee81ca0
2 changed files with 12 additions and 2 deletions
  1. 2
    2
      net/knxd/Makefile
  2. 10
    0
      net/knxd/patches/0100-musl-compat

+ 2
- 2
net/knxd/Makefile View File

@@ -11,12 +11,12 @@
11 11
 include $(TOPDIR)/rules.mk
12 12
 
13 13
 PKG_NAME:=knxd
14
-PKG_VERSION=2015-06-02-$(PKG_SOURCE_VERSION)
14
+PKG_VERSION=2015-06-27-$(PKG_SOURCE_VERSION)
15 15
 PKG_RELEASE:=1
16 16
 
17 17
 PKG_SOURCE_PROTO:=git
18 18
 PKG_SOURCE_URL:=https://github.com/knxd/knxd.git
19
-PKG_SOURCE_VERSION:=3d3b1a5e8112397d297625d673a2a94507f9ebce
19
+PKG_SOURCE_VERSION:=50e7f6e6bfa13c2b6140b0f76aaa70234bf44b1d
20 20
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)
21 21
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz
22 22
 

+ 10
- 0
net/knxd/patches/0100-musl-compat View File

@@ -0,0 +1,10 @@
1
+--- a/src/examples/common.h	2015-06-27 15:20:15.266563893 +0200
2
++++ b/src/examples/common.h	2015-06-27 15:23:09.406457392 +0200
3
+@@ -20,6 +20,7 @@
4
+ #include <stdlib.h>
5
+ #include <errno.h>
6
+ #include <unistd.h>
7
++#include <sys/select.h>
8
+ #include "eibclient.h"
9
+ 
10
+ /** unsigned char*/