|
@@ -0,0 +1,89 @@
|
|
1
|
+--- a/configure.ac
|
|
2
|
++++ b/configure.ac
|
|
3
|
+@@ -123,17 +123,6 @@ AC_MSG_RESULT($UINT32_TYPE)
|
|
4
|
+ AC_DEFINE_UNQUOTED(UINT32_TYPE,$UINT32_TYPE,unsigned 32 bit integer type)
|
|
5
|
+
|
|
6
|
+ dnl ----------------------------------------------------------------------
|
|
7
|
+-dnl Internationalization
|
|
8
|
+-
|
|
9
|
+-GETTEXT_PACKAGE=ccrypt
|
|
10
|
+-AC_SUBST(GETTEXT_PACKAGE)
|
|
11
|
+-AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [Package name for gettext])
|
|
12
|
+-
|
|
13
|
+-AM_GNU_GETTEXT
|
|
14
|
+-AM_GNU_GETTEXT_VERSION([0.14.3])
|
|
15
|
+-IT_PO_SUBDIR(po)
|
|
16
|
+-
|
|
17
|
+-dnl ----------------------------------------------------------------------
|
|
18
|
+ dnl Libtool (needed by intl/)
|
|
19
|
+
|
|
20
|
+ LT_INIT
|
|
21
|
+@@ -153,9 +142,7 @@ AC_SUBST(TAR)
|
|
22
|
+ dnl ----------------------------------------------------------------------
|
|
23
|
+ AC_CONFIG_FILES([doc/ccrypt.1
|
|
24
|
+ doc/ccguess.1
|
|
25
|
+- po/Makefile.in
|
|
26
|
+ m4/Makefile
|
|
27
|
+- intl/Makefile
|
|
28
|
+ Makefile
|
|
29
|
+ src/Makefile
|
|
30
|
+ emacs/Makefile
|
|
31
|
+--- a/Makefile.am
|
|
32
|
++++ b/Makefile.am
|
|
33
|
+@@ -4,7 +4,7 @@
|
|
34
|
+
|
|
35
|
+ ## Process this file with automake to produce Makefile.in
|
|
36
|
+
|
|
37
|
+-SUBDIRS = m4 po intl src emacs doc check
|
|
38
|
++SUBDIRS = m4 src emacs doc check
|
|
39
|
+
|
|
40
|
+ EXTRA_DIST = m4/ChangeLog config.rpath README-WIN
|
|
41
|
+
|
|
42
|
+--- a/Makefile.in
|
|
43
|
++++ b/Makefile.in
|
|
44
|
+@@ -36,7 +36,7 @@ host_triplet = @host@
|
|
45
|
+ subdir = .
|
|
46
|
+ DIST_COMMON = README $(am__configure_deps) $(srcdir)/Makefile.am \
|
|
47
|
+ $(srcdir)/Makefile.in $(srcdir)/config.h.in \
|
|
48
|
+- $(top_srcdir)/configure $(top_srcdir)/intl/Makefile.in \
|
|
49
|
++ $(top_srcdir)/configure \
|
|
50
|
+ ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS config.guess \
|
|
51
|
+ config.rpath config.sub depcomp elisp-comp install-sh \
|
|
52
|
+ ltmain.sh missing mkinstalldirs
|
|
53
|
+@@ -66,7 +66,7 @@ am__CONFIG_DISTCLEAN_FILES = config.stat
|
|
54
|
+ configure.lineno config.status.lineno
|
|
55
|
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
|
56
|
+ CONFIG_HEADER = config.h
|
|
57
|
+-CONFIG_CLEAN_FILES = intl/Makefile
|
|
58
|
++CONFIG_CLEAN_FILES =
|
|
59
|
+ CONFIG_CLEAN_VPATH_FILES =
|
|
60
|
+ SOURCES =
|
|
61
|
+ DIST_SOURCES =
|
|
62
|
+@@ -277,7 +277,7 @@ target_alias = @target_alias@
|
|
63
|
+ top_build_prefix = @top_build_prefix@
|
|
64
|
+ top_builddir = @top_builddir@
|
|
65
|
+ top_srcdir = @top_srcdir@
|
|
66
|
+-SUBDIRS = m4 po intl src emacs doc check
|
|
67
|
++SUBDIRS = m4 src emacs doc check
|
|
68
|
+ EXTRA_DIST = m4/ChangeLog config.rpath README-WIN
|
|
69
|
+ ACLOCAL_AMFLAGS = -I m4
|
|
70
|
+ all: config.h
|
|
71
|
+--- a/src/Makefile.am
|
|
72
|
++++ b/src/Makefile.am
|
|
73
|
+@@ -56,4 +56,4 @@ uninstall-local:
|
|
74
|
+ # internationalization stuff
|
|
75
|
+ localedir = $(datadir)/locale
|
|
76
|
+ INCLUDES = -I../intl -I$(top_srcdir)/intl -DLOCALEDIR=\"$(localedir)\"
|
|
77
|
+-LIBS = @LIBINTL@ @LIBS@
|
|
78
|
++LIBS = @LIBS@
|
|
79
|
+--- a/src/Makefile.in
|
|
80
|
++++ b/src/Makefile.in
|
|
81
|
+@@ -159,7 +159,7 @@ LDFLAGS = @LDFLAGS@
|
|
82
|
+ LIBICONV = @LIBICONV@
|
|
83
|
+ LIBINTL = @LIBINTL@
|
|
84
|
+ LIBOBJS = @LIBOBJS@
|
|
85
|
+-LIBS = @LIBINTL@ @LIBS@
|
|
86
|
++LIBS = @LIBS@
|
|
87
|
+ LIBTOOL = @LIBTOOL@
|
|
88
|
+ LIPO = @LIPO@
|
|
89
|
+ LN_S = @LN_S@
|