瀏覽代碼

python-setuptools: revamp installation procedure, update to 18.1

It's better to install setuptools-enabled Python packages with a special
flag that makes a flatter structure of the egg and does not create
site.py file. Already done for python-pip recently. Also, version was
bumped to 18.1.

Signed-off-by: Jan Čermák <jan.cermak@nic.cz>
Jan Čermák 9 年之前
父節點
當前提交
7964fbf4b2
共有 1 個檔案被更改,包括 4 行新增3 行删除
  1. 4
    3
      lang/python-setuptools/Makefile

+ 4
- 3
lang/python-setuptools/Makefile 查看文件

@@ -8,12 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=python-setuptools
11
-PKG_VERSION:=18.0.1
11
+PKG_VERSION:=18.1
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=setuptools-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=https://pypi.python.org/packages/source/s/setuptools/
16
-PKG_MD5SUM:=cecd172c9ff7fd5f2e16b2fcc88bba51
16
+PKG_MD5SUM:=f72e87f34fbf07f299f6cb46256a0b06
17 17
 
18 18
 PKG_BUILD_DIR:=$(BUILD_DIR)/setuptools-$(PKG_VERSION)
19 19
 
@@ -35,7 +35,8 @@ endef
35 35
 
36 36
 define Build/Compile
37 37
 	$(call Build/Compile/PyMod,,\
38
-		install --prefix="$(PKG_INSTALL_DIR)/usr" \
38
+		install --root="$(PKG_INSTALL_DIR)" --prefix="/usr" \
39
+		--single-version-externally-managed \
39 40
 	)
40 41
 endef
41 42