Browse Source

opensc: fix compilation

Signed-off-by: Etienne CHAMPETIER <etienne.champetier@free.fr>
Etienne CHAMPETIER 10 years ago
parent
commit
79bdb90a66
1 changed files with 4 additions and 3 deletions
  1. 4
    3
      utils/opensc/Makefile

+ 4
- 3
utils/opensc/Makefile View File

@@ -47,7 +47,7 @@ define Package/libopensc-pkcs11
47 47
   CATEGORY:=Libraries
48 48
   TITLE:=OpenSC - PKCS11 provider
49 49
   URL:=https://github.com/OpenSC/OpenSC/wiki
50
-  DEPENDS:=libopensc
50
+  DEPENDS:=+libopensc
51 51
 endef
52 52
 
53 53
 define Package/libopensc-pkcs11/description
@@ -59,6 +59,7 @@ define Package/libpkcs11-spy
59 59
   CATEGORY:=Libraries
60 60
   TITLE:=PKCS11 spying wrapper
61 61
   URL:=https://github.com/OpenSC/OpenSC/wiki
62
+  DEPENDS:=+libopensc-pkcs11
62 63
 endef
63 64
 
64 65
 define Package/libpkcs11-spy/dscription
@@ -84,7 +85,7 @@ define Package/opensc-utils-$(subst _,-,$(firstword $(subst :, ,$(1))))
84 85
   URL:=https://github.com/OpenSC/OpenSC/wiki
85 86
   SECTION:=utils
86 87
   CATEGORY:=Utilities
87
-  DEPENDS:=opensc-utils $(wordlist 2,$(words $(subst :, ,$(1))),$(subst :, ,$(1)))
88
+  DEPENDS:=+opensc-utils $(wordlist 2,$(words $(subst :, ,$(1))),$(subst :, ,$(1)))
88 89
 endef
89 90
 endef
90 91
 
@@ -94,7 +95,7 @@ define Package/libopensc-profile-$(subst _,-,$(firstword $(subst :, ,$(1))))
94 95
   URL:=https://github.com/OpenSC/OpenSC/wiki
95 96
   SECTION:=lib
96 97
   CATEGORY:=Libraries
97
-  DEPENDS:=libopensc
98
+  DEPENDS:=+libopensc
98 99
 endef
99 100
 endef
100 101