Browse Source

lang/perl-www-curl: Properly link against libcurl

Signed-off-by: Marcel Denia <naoir@gmx.net>
Marcel Denia 10 years ago
parent
commit
7a459369f7
1 changed files with 11 additions and 0 deletions
  1. 11
    0
      lang/perl-www-curl/patches/200-fix_default_lflags.patch

+ 11
- 0
lang/perl-www-curl/patches/200-fix_default_lflags.patch View File

@@ -0,0 +1,11 @@
1
+--- a/Makefile.PL
2
++++ b/Makefile.PL
3
+@@ -39,7 +39,7 @@ repository		'http://github.com/szbalint/
4
+ #print "The version is $version\n";
5
+ 
6
+ my @includes = qw();
7
+-my ($cflags,$lflags, $ldflags) = ('','','');
8
++my ($cflags,$lflags, $ldflags) = ('','-lcurl','');
9
+ 
10
+ # You may need to specify where to find curl.h on your platform
11
+ # These are guesses only, in case curl-config is not telling us.