Browse Source

mosquitto: optionally include mosquitto_passwd utility

Many users of the SSL build of mosquitto need the passwd utility for
managing keys.

Fixes github issue #1909

Signed-off-by: Karl Palsson <karlp@remake.is>
Karl Palsson 9 years ago
parent
commit
7a6a575887
2 changed files with 10 additions and 0 deletions
  1. 7
    0
      net/mosquitto/Config.in
  2. 3
    0
      net/mosquitto/Makefile

+ 7
- 0
net/mosquitto/Config.in View File

@@ -4,3 +4,10 @@ config MOSQUITTO_LWS
4 4
     default y
5 5
     help
6 6
         Includes websockets support in the broker, via libwebsockets
7
+
8
+config MOSQUITTO_PASSWD
9
+    bool "Include mosquitto_passwd utility"
10
+    depends on PACKAGE_mosquitto
11
+    default y
12
+    help
13
+        mosquitto_passwd is a tool for managing password files for mosquitto.

+ 3
- 0
net/mosquitto/Makefile View File

@@ -148,6 +148,9 @@ Package/$(PKG_NAME)-nossl/conffiles = $(Package/$(PKG_NAME)/conffiles)
148 148
 define Package/$(PKG_NAME)/install
149 149
 	$(INSTALL_DIR) $(1)/usr/sbin
150 150
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mosquitto $(1)/usr/sbin/mosquitto
151
+ifeq ($(CONFIG_MOSQUITTO_PASSWD),y)
152
+        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mosquitto_passwd $(1)/usr/sbin
153
+endif
151 154
 	$(INSTALL_DIR) $(1)/etc/mosquitto
152 155
 	$(INSTALL_CONF) $(PKG_BUILD_DIR)/mosquitto.conf $(1)/etc/mosquitto/mosquitto.conf
153 156
 	$(INSTALL_DIR) $(1)/etc/init.d