|
@@ -8,14 +8,11 @@
|
8
|
8
|
include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=gnunet
|
11
|
|
-PKG_SOURCE_VERSION:=36019
|
|
11
|
+PKG_SOURCE_VERSION:=36048
|
12
|
12
|
PKG_VERSION:=0.10.1-svn$(PKG_SOURCE_VERSION)
|
13
|
13
|
PKG_RELEASE:=1
|
14
|
14
|
|
15
|
15
|
# ToDo:
|
16
|
|
-# - break-out transports
|
17
|
|
-# -> get rid of microhttpd and gnurl dependency for gns and vpn
|
18
|
|
-# requires upstream to split config files
|
19
|
16
|
# - break-out {peer,name,data}store for each backend
|
20
|
17
|
# - package testing stuff
|
21
|
18
|
|
|
@@ -74,8 +71,8 @@ define Package/gnunet/description
|
74
|
71
|
well as many missing features in this release.
|
75
|
72
|
|
76
|
73
|
This package provides the core components of GNUnet including the
|
77
|
|
- CADET routing engine, a DHT implementation and most transports as well
|
78
|
|
- as their helpers.
|
|
74
|
+ CADET routing engine, a DHT implementation and basic transports as
|
|
75
|
+ well as their helpers.
|
79
|
76
|
endef
|
80
|
77
|
|
81
|
78
|
define BuildComponent
|
|
@@ -144,9 +141,7 @@ define Package/gnunet/install
|
144
|
141
|
done )
|
145
|
142
|
|
146
|
143
|
( for plug in ats_proportional block_dht block_regex datacache_heap \
|
147
|
|
- transport_http_client transport_http_server \
|
148
|
|
- transport_https_client transport_https_server \
|
149
|
|
- transport_tcp transport_udp transport_unix transport_wlan; do \
|
|
144
|
+ transport_tcp transport_udp transport_unix; do \
|
150
|
145
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/gnunet/libgnunet_plugin_$$$$plug*.so $(1)/usr/lib/gnunet ; \
|
151
|
146
|
done )
|
152
|
147
|
|
|
@@ -185,6 +180,15 @@ PLUGIN_conversation:=gnsrecord_conversation
|
185
|
180
|
LIBEXEC_conversation:=helper-audio-playback helper-audio-record
|
186
|
181
|
CONF_conversation:=conversation
|
187
|
182
|
|
|
183
|
+DEPENDS_transport-http_client:=+libgnurl
|
|
184
|
+PLUGIN_transport-http_client:=transport_http_client transport_https_client
|
|
185
|
+
|
|
186
|
+DEPENDS_transport-http_server:=+libmicrohttpd
|
|
187
|
+PLUGIN_transport-http_server:=transport_http_server transport_https_server
|
|
188
|
+
|
|
189
|
+PLUGIN_transport-wifi:=transport_wlan
|
|
190
|
+LIBEXEC_transport-wifi:=helper-transport-wlan
|
|
191
|
+
|
188
|
192
|
DEPENDS_experiments:=+libglpk
|
189
|
193
|
PLUGIN_experiments:=ats_mlp ats_ril
|
190
|
194
|
|
|
@@ -192,7 +196,7 @@ DEPENDS_fs:=+gnunet-datastore +libextractor
|
192
|
196
|
BIN_fs:=auto-share directory download download-manager.scm fs publish unindex search
|
193
|
197
|
LIB_fs:=fs
|
194
|
198
|
PLUGIN_fs:=block_fs
|
195
|
|
-LIB_EXEC_fs:=helper-fs-publish service-fs
|
|
199
|
+LIBEXEC_fs:=helper-fs-publish service-fs
|
196
|
200
|
CONF_fs:=fs
|
197
|
201
|
|
198
|
202
|
DEPENDS_gns:=+gnunet-vpn
|
|
@@ -226,7 +230,7 @@ PLUGIN_transport-bluetooth:=transport_bluetooth
|
226
|
230
|
LIBEXEC_transport-bluetooth:=helper-transport-bluetooth
|
227
|
231
|
|
228
|
232
|
DEPENDS_utils:=+certtool +openssl-util
|
229
|
|
-BIN_utils:=config gns-import.sh gns-proxy-setup-ca transport-certificate-creation
|
|
233
|
+BIN_utils:=config gns-proxy-setup-ca transport-certificate-creation
|
230
|
234
|
|
231
|
235
|
DEPENDS_vpn:=+kmod-tun
|
232
|
236
|
LIB_vpn:=tun vpn
|
|
@@ -240,6 +244,9 @@ $(eval $(call BuildComponent,fs,file-sharing components,))
|
240
|
244
|
$(eval $(call BuildComponent,gns,name resolution components,y))
|
241
|
245
|
$(eval $(call BuildComponent,datastore,storage components,))
|
242
|
246
|
$(eval $(call BuildComponent,transport-bluetooth,bluetooth transport,))
|
|
247
|
+$(eval $(call BuildComponent,transport-http_client,HTTP/HTTPS client transport,y))
|
|
248
|
+$(eval $(call BuildComponent,transport-http_server,HTTP/HTTPS server transport,))
|
|
249
|
+$(eval $(call BuildComponent,transport-wlan,WLAN transport,))
|
243
|
250
|
$(eval $(call BuildComponent,utils,administration utililties,))
|
244
|
251
|
$(eval $(call BuildComponent,vpn,vpn components,y))
|
245
|
252
|
$(eval $(call BuildComponent,mysql,mySQL datastore backend,))
|