Browse Source

horst: update to version 4.1

4.1 has an important bugfix for platforms (such as ARM cns3xxx) where "char"
does not default to "signed char" and other bugfixes.

Also build with debugging enabled (-D flag) to enable debugging, the size
increase is just +336B (on platform au1000).
Bruno Randolf 10 years ago
parent
commit
7bab6e0995
1 changed files with 4 additions and 2 deletions
  1. 4
    2
      net/horst/Makefile

+ 4
- 2
net/horst/Makefile View File

@@ -8,14 +8,14 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=horst
11
-PKG_VERSION:=4.0
11
+PKG_VERSION:=4.1
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-git.tar.gz
15 15
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
16 16
 PKG_SOURCE_URL:=git://br1.einfach.org/horst
17 17
 PKG_SOURCE_PROTO:=git
18
-PKG_SOURCE_VERSION:=version-4.0
18
+PKG_SOURCE_VERSION:=version-$(PKG_VERSION)
19 19
 
20 20
 PKG_MAINTAINER:=Bruno Randolf <br1@einfach.org>
21 21
 PKG_LICENSE:=GPL-2.0+
@@ -25,6 +25,8 @@ PKG_BUILD_PARALLEL:=1
25 25
 
26 26
 include $(INCLUDE_DIR)/package.mk
27 27
 
28
+MAKE_FLAGS += DEBUG=1
29
+
28 30
 define Package/horst
29 31
 	SECTION:=net
30 32
 	CATEGORY:=Network