Browse Source

gammu: disable libdbi support explicitly

Fixes a dependency error when libdbi was built before gammu

Signed-off-by: Nicolas Thill <nico@openwrt.org>
Nicolas Thill 10 years ago
parent
commit
7be03a4be0
2 changed files with 36 additions and 1 deletions
  1. 2
    1
      utils/gammu/Makefile
  2. 34
    0
      utils/gammu/patches/004-cmake_libdbi_optional.patch

+ 2
- 1
utils/gammu/Makefile View File

@@ -35,7 +35,8 @@ endef
35 35
 CONFIGURE_ARGS:= \
36 36
 	--prefix=/usr \
37 37
 	--cross-root="$(STAGING_DIR) $(TOOLCHAIN_DIR)" \
38
-	--enable-shared
38
+	--enable-shared \
39
+	--without-libdbi \
39 40
 
40 41
 define Build/Compile
41 42
 	$(MAKE) -C $(PKG_BUILD_DIR) \

+ 34
- 0
utils/gammu/patches/004-cmake_libdbi_optional.patch View File

@@ -0,0 +1,34 @@
1
+--- a/configure
2
++++ b/configure
3
+@@ -36,6 +36,7 @@ Usage: ./configure [options]
4
+ --with-python=<path> path to Python interpreter
5
+ --without-gnapplet  disable installation of gnapplet
6
+ --without-completion disable installation of bash completion script
7
++--without-libdbi	disable libdbi support
8
+ 
9
+ All enable params have their disable counterparts.
10
+ 
11
+@@ -61,6 +62,7 @@ CMAKE_PYTHON=
12
+ CMAKE_GNAP=
13
+ CMAKE_COMPLETE=
14
+ CMAKE_ICONV=
15
++CMAKE_LIBDBI=
16
+ 
17
+ # process command line
18
+ while [ "$#" -gt 0 ] ; do
19
+@@ -120,6 +122,9 @@ while [ "$#" -gt 0 ] ; do
20
+         --without-completion)
21
+             CMAKE_COMPLETE="-DINSTALL_BASH_COMPLETION=OFF"
22
+             ;;
23
++        --without-libdbi)
24
++            CMAKE_LIBDBI="-DWITH_LibDBI=OFF"
25
++            ;;
26
+         --build=*)
27
+             ;;
28
+         --disable-dependency-tracking)
29
+@@ -156,4 +161,4 @@ fi
30
+ cd "$BUILD_DIR"
31
+ 
32
+ # invoke cmake to do configuration
33
+-cmake $SOURCE_DIR $CMAKE_ROOT $CMAKE_PREFIX $CMAKE_SHARED $CMAKE_DEBUG $CMAKE_BACKUP $CMAKE_CROSS $CMAKE_PROTECTION $CMAKE_PYTHON $CMAKE_GNAP $CMAKE_COMPLETE $CMAKE_ICONV
34
++cmake $SOURCE_DIR $CMAKE_ROOT $CMAKE_PREFIX $CMAKE_SHARED $CMAKE_DEBUG $CMAKE_BACKUP $CMAKE_CROSS $CMAKE_PROTECTION $CMAKE_PYTHON $CMAKE_GNAP $CMAKE_COMPLETE $CMAKE_ICONV $CMAKE_LIBDBI