Browse Source

net: mosquitto: Fix libwebsockets detection

Patch suggested from upstream.  Bumping release and including the patch
directly until a point release is available.

Signed-off-by: Karl Palsson <karlp@remake.is>
Karl Palsson 10 years ago
parent
commit
7c2f386e2d
2 changed files with 14 additions and 1 deletions
  1. 1
    1
      net/mosquitto/Makefile
  2. 13
    0
      net/mosquitto/patches/100-libwebsockets-fixes.patch

+ 1
- 1
net/mosquitto/Makefile View File

@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
10 10
 
11 11
 PKG_NAME:=mosquitto
12 12
 PKG_VERSION:=1.4
13
-PKG_RELEASE:=1
13
+PKG_RELEASE:=2
14 14
 PKG_LICENSE:=BSD-3-Clause
15 15
 PKG_LICENSE_FILES:=LICENSE.txt
16 16
 

+ 13
- 0
net/mosquitto/patches/100-libwebsockets-fixes.patch View File

@@ -0,0 +1,13 @@
1
+diff --git a/src/websockets.c b/src/websockets.c
2
+index 95f8a81..cf2b5e7 100644
3
+--- a/src/websockets.c
4
++++ b/src/websockets.c
5
+@@ -72,7 +72,7 @@ struct libws_http_data {
6
+ 	FILE *fptr;
7
+ };
8
+ 
9
+-#ifndef HTTP_STATUS_NOT_FOUND
10
++#ifndef LWS_FEATURE_SERVE_HTTP_FILE_HAS_OTHER_HEADERS_ARG
11
+ 	/* This is libwebsockets 1.2.x or earlier, we have to degrade our capabilities.
12
+ 	 * Once lws 1.3 is widely available this should be removed. */
13
+ #	define LWS_IS_OLD