瀏覽代碼

php5: gd: do not link against libiconv (fixes #706)

This commit adds a patch to enforce the usage of an alternative
code path, preventing the need of libiconv in the bundled libgd
of php.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Michael Heimpold 10 年之前
父節點
當前提交
7c4ed7731c
共有 2 個文件被更改,包括 15 次插入1 次删除
  1. 1
    1
      lang/php5/Makefile
  2. 14
    0
      lang/php5/patches/800-gd-iconv.patch

+ 1
- 1
lang/php5/Makefile 查看文件

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=php
11 11
 PKG_VERSION:=5.4.36
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
15 15
 

+ 14
- 0
lang/php5/patches/800-gd-iconv.patch 查看文件

@@ -0,0 +1,14 @@
1
+--- a/ext/gd/libgd/gdkanji.c
2
++++ b/ext/gd/libgd/gdkanji.c
3
+@@ -9,6 +9,11 @@
4
+ #include "gdhelpers.h"
5
+ 
6
+ #include <stdarg.h>
7
++
8
++/* force usage of internal conversation routine */
9
++#undef HAVE_ICONV_H
10
++#undef HAVE_ICONV
11
++
12
+ #if defined(HAVE_ICONV_H) || defined(HAVE_ICONV)
13
+ #include <iconv.h>
14
+ #ifdef HAVE_ERRNO_H