Browse Source

ocserv: removed unecessary instructions and script

Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Nikos Mavrogiannopoulos 9 years ago
parent
commit
7c9c18e756
3 changed files with 1 additions and 14 deletions
  1. 0
    1
      net/ocserv/Makefile
  2. 1
    2
      net/ocserv/README
  3. 0
    11
      net/ocserv/files/ocserv-script

+ 0
- 1
net/ocserv/Makefile View File

@@ -92,7 +92,6 @@ define Package/ocserv/install
92 92
 	$(INSTALL_DIR) $(1)/usr/bin
93 93
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ocpasswd $(1)/usr/bin/
94 94
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/occtl $(1)/usr/bin/
95
-	$(INSTALL_BIN) ./files/ocserv-script $(1)/usr/bin/
96 95
 	$(INSTALL_DIR) $(1)/etc/init.d
97 96
 	$(INSTALL_BIN) ./files/ocserv.init $(1)/etc/init.d/ocserv
98 97
 	$(INSTALL_DIR) $(1)/etc/ocserv

+ 1
- 2
net/ocserv/README View File

@@ -18,7 +18,6 @@ config ocserv 'config'
18 18
 	option netmask '255.255.255.0'
19 19
 	option ipaddr '10.100.3.0'
20 20
 	option auth 'plain'
21
-	option zone 'vpn'
22 21
 	option default_domain 'lan'
23 22
 	option compression '1'
24 23
 	option enable '1'
@@ -57,7 +56,7 @@ config interface 'vpn'
57 56
 ----/etc/config/firewall-----------------------------------------
58 57
 config zone
59 58
         option input 'ACCEPT'
60
-        option forward 'REJECT'
59
+        option forward 'ACCEPT'
61 60
         option output 'ACCEPT'
62 61
         option name 'vpn'
63 62
         option device 'vpns+'

+ 0
- 11
net/ocserv/files/ocserv-script View File

@@ -1,11 +0,0 @@
1
-#!/bin/sh
2
-
3
-ZONE=`uci get ocserv.config.zone`
4
-
5
-if [ "$REASON" = "connect" ];then
6
-	env -i ACTION=ifup INTERFACE="$ZONE" DEVICE=$DEVICE /sbin/hotplug-call "iface"
7
-else
8
-	env -i ACTION=ifdown INTERFACE="$ZONE" DEVICE=$DEVICE /sbin/hotplug-call "iface"
9
-fi
10
-
11
-exit 0