Browse Source

net/iodine: upgrade to version 0.7.0

This is compatible to 0.6.0-rc1 client and servers and fixes an
authentication bypass bug (CVE-2014-4168).

Signed-off-by: Uwe Kleine-König <uwe+openwrt@kleine-koenig.org>
Uwe Kleine-König 10 years ago
parent
commit
7d5784fc51
2 changed files with 17 additions and 15 deletions
  1. 3
    3
      net/iodine/Makefile
  2. 14
    12
      net/iodine/patches/010-cross-compile.patch

+ 3
- 3
net/iodine/Makefile View File

@@ -8,12 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=iodine
11
-PKG_VERSION:=0.6.0-rc1
12
-PKG_RELEASE:=5
11
+PKG_VERSION:=0.7.0
12
+PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://code.kryo.se/iodine/
16
-PKG_MD5SUM:=a15bb4faba020d217016fde6e231074a
16
+PKG_MD5SUM:=fdbf3b81cd69caf5230d76a8b039fd99
17 17
 
18 18
 include $(INCLUDE_DIR)/package.mk
19 19
 

+ 14
- 12
net/iodine/patches/010-cross-compile.patch View File

@@ -1,22 +1,24 @@
1
---- a/src/osflags
2
-+++ b/src/osflags
3
-@@ -16,9 +16,6 @@ link)
1
+--- iodine-0.7.0.orig/src/osflags
2
++++ iodine-0.7.0/src/osflags
3
+@@ -16,12 +16,6 @@ link)
4 4
  		windows32)
5 5
  			echo '-lws2_32 -liphlpapi';
6 6
  		;;
7 7
 -		Linux)
8
--			[ -e /usr/include/selinux/selinux.h ] && echo '-lselinux';
8
+-			FLAGS="";
9
+-			[ -e /usr/include/selinux/selinux.h ] && FLAGS="$FLAGS -lselinux";
10
+-			[ -e /usr/include/systemd/sd-daemon.h ] && FLAGS="$FLAGS -lsystemd-daemon";
11
+-			echo $FLAGS;
9 12
 -		;;
10 13
  	esac
11 14
  	;;
12 15
  cflags)
13
-@@ -26,9 +23,6 @@ cflags)
14
- 		BeOS)
15
- 			echo '-Dsocklen_t=int';
16
+@@ -34,8 +28,6 @@ cflags)
17
+ 		;;
18
+ 		Linux)
19
+ 			FLAGS="-D_GNU_SOURCE"
20
+-			[ -e /usr/include/selinux/selinux.h ] && FLAGS="$FLAGS -DHAVE_SETCON";
21
+-			[ -e /usr/include/systemd/sd-daemon.h ] && FLAGS="$FLAGS -DHAVE_SYSTEMD";
22
+ 			echo $FLAGS;
16 23
  		;;
17
--		Linux)
18
--			[ -e /usr/include/selinux/selinux.h ] && echo '-DHAVE_SETCON';
19
--		;;
20 24
  	esac
21
- ;;
22
- *)