Browse Source

freeradius2: completely disable runtime OpenSSL version checks

Whenever we ship fixed libopenssl binaries in DD, the Freeradius daemon fails
at startup because it detects a mismatch of the build time and runtime OpenSSL
version.

Since our OpenSSL updates for DD are ABI compatible we do not need or even want
this superflous check. Removing it saves us the effort to rebuild Freeradius
after every OpenSSL version bump.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Jo-Philipp Wich 9 years ago
parent
commit
7dadd12850
1 changed files with 3 additions and 2 deletions
  1. 3
    2
      net/freeradius2/Makefile

+ 3
- 2
net/freeradius2/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2008-2014 OpenWrt.org
2
+# Copyright (C) 2008-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=freeradius2
11 11
 PKG_VERSION:=2.2.8
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE:=freeradius-server-$(PKG_VERSION).tar.bz2
15 15
 PKG_SOURCE_URL:=\
@@ -350,6 +350,7 @@ CONFIGURE_ARGS+= \
350 350
 	$(if $(CONFIG_FREERADIUS_OPENSSL),--with,--without)-openssl \
351 351
 	$(if $(CONFIG_FREERADIUS_OPENSSL),--with-openssl-includes="$(STAGING_DIR)/usr/include",) \
352 352
 	$(if $(CONFIG_FREERADIUS_OPENSSL),--with-openssl-libraries="$(STAGING_DIR)/usr/lib",) \
353
+	$(if $(CONFIG_FREERADIUS_OPENSSL),--disable-openssl-version-check,) \
353 354
 	--with-system-libtool \
354 355
 	--with-system-libltdl \
355 356
 	--enable-strict-dependencies \