|
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
|
10
|
10
|
|
11
|
11
|
PKG_NAME:=bridge-utils
|
12
|
12
|
PKG_VERSION:=1.5
|
13
|
|
-PKG_RELEASE:=3
|
|
13
|
+PKG_RELEASE:=4
|
14
|
14
|
|
15
|
15
|
PKG_SOURCE_PROTO:=git
|
16
|
16
|
PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/shemminger/bridge-utils.git
|
|
@@ -49,4 +49,11 @@ define Package/bridge/install
|
49
|
49
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/brctl/brctl $(1)/usr/sbin
|
50
|
50
|
endef
|
51
|
51
|
|
|
52
|
+define Package/bridge/prerm
|
|
53
|
+#!/bin/sh
|
|
54
|
+$${IPKG_INSTROOT}/bin/busybox brctl -h 2>&1 | grep -q BusyBox && \
|
|
55
|
+ln -sf ../../bin/busybox $${IPKG_INSTROOT}/usr/sbin/brctl
|
|
56
|
+exit 0
|
|
57
|
+endef
|
|
58
|
+
|
52
|
59
|
$(eval $(call BuildPackage,bridge))
|