Bladeren bron

pciutils: remove eudev dependency

Disable udev hwdb support instead of depending on eudev. This restores
the old behavior of pciutils. It never depended on udev.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Stijn Tintel 8 jaren geleden
bovenliggende
commit
7ea7af5125
1 gewijzigde bestanden met toevoegingen van 3 en 2 verwijderingen
  1. 3
    2
      utils/pciutils/Makefile

+ 3
- 2
utils/pciutils/Makefile Bestand weergeven

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=pciutils
11 11
 PKG_VERSION:=3.4.1
12
-PKG_RELEASE:=2
12
+PKG_RELEASE:=3
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils
@@ -29,7 +29,7 @@ define Package/pciutils
29 29
   CATEGORY:=Utilities
30 30
   TITLE:=Linux PCI Utilities
31 31
   URL:=http://mj.ucw.cz/pciutils.shtml
32
-  DEPENDS:=+eudev +libkmod +zlib
32
+  DEPENDS:=+libkmod +zlib
33 33
 endef
34 34
 
35 35
 define Package/pciutils/description
@@ -48,6 +48,7 @@ MAKE_FLAGS += \
48 48
 	CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
49 49
 	PREFIX="/usr" \
50 50
 	HOST="$(GNU_TARGET_NAME)" \
51
+	HWDB="no" \
51 52
 	ZLIB="yes"
52 53
 
53 54
 ifneq ($(CONFIG_USE_GLIBC),)