|
@@ -1,72 +0,0 @@
|
1
|
|
-#
|
2
|
|
-# Copyright (C) 2005-2008 OpenWrt.org
|
3
|
|
-#
|
4
|
|
-# This is free software, licensed under the GNU General Public License v2.
|
5
|
|
-# See /LICENSE for more information.
|
6
|
|
-#
|
7
|
|
-
|
8
|
|
-include $(TOPDIR)/rules.mk
|
9
|
|
-
|
10
|
|
-PKG_NAME:=OpenSC
|
11
|
|
-PKG_VERSION:=0.13.0
|
12
|
|
-PKG_RELEASE:=1
|
13
|
|
-
|
14
|
|
-PKG_SOURCE:=$(PKG_VERSION).tar.gz
|
15
|
|
-PKG_SOURCE_URL:=https://github.com/OpenSC/OpenSC/archive/
|
16
|
|
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
17
|
|
-PKG_MD5SUM:=92ed0041be8e5c53aa48c371b090b6cd
|
18
|
|
-
|
19
|
|
-PKG_FIXUP:=autoreconf
|
20
|
|
-PKG_INSTALL:=1
|
21
|
|
-
|
22
|
|
-include $(INCLUDE_DIR)/package.mk
|
23
|
|
-
|
24
|
|
-define Package/OpenSC
|
25
|
|
- SECTION:=libs
|
26
|
|
- CATEGORY:=Libraries
|
27
|
|
- TITLE:=tools and libraries for smart cards
|
28
|
|
- URL:=https://github.com/OpenSC/OpenSC/wiki
|
29
|
|
- DEPENDS+= +libpcsclite +libopenssl +pcscd
|
30
|
|
-endef
|
31
|
|
-
|
32
|
|
-define Package/OpenSC/description
|
33
|
|
- OpenSC provides a set of libraries and utilities to work with smart cards.
|
34
|
|
- Its main focus is on cards that support cryptographic operations, and facilitate
|
35
|
|
- their use in security applications such as authentication, mail encryption and
|
36
|
|
- digital signatures. OpenSC implements the PKCS11 API so applications supporting
|
37
|
|
- this API (such as Mozilla Firefox and Thunderbird) can use it. On the card OpenSC
|
38
|
|
- implements the PKCS15 standard and aims to be compatible with every software/card
|
39
|
|
- that does so, too.
|
40
|
|
-endef
|
41
|
|
-
|
42
|
|
-CONFIGURE_ARGS += \
|
43
|
|
- --disable-assert \
|
44
|
|
- --enable-pcsc \
|
45
|
|
- --enable-sm \
|
46
|
|
- --disable-zlib \
|
47
|
|
- --with-pcsc-provider=libpcsclite.so.1
|
48
|
|
-
|
49
|
|
-define Build/InstallDev
|
50
|
|
- $(INSTALL_DIR) $(1)/usr/lib
|
51
|
|
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libopensc.{a,so*} $(1)/usr/lib/
|
52
|
|
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsmm-local.{a,so*} $(1)/usr/lib/
|
53
|
|
-endef
|
54
|
|
-
|
55
|
|
-define Package/OpenSC/install
|
56
|
|
- $(INSTALL_DIR) $(1)/usr/bin
|
57
|
|
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/opensc-tool $(1)/usr/bin
|
58
|
|
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/pkcs15-tool $(1)/usr/bin
|
59
|
|
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/pkcs15-init $(1)/usr/bin
|
60
|
|
- $(INSTALL_DIR) $(1)/usr/lib
|
61
|
|
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libopensc.so.* $(1)/usr/lib/
|
62
|
|
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/opensc-pkcs11.so $(1)/usr/lib/
|
63
|
|
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsmm-local.so.* $(1)/usr/lib/
|
64
|
|
-ifeq ($(CONFIG_PACKAGE_p11-kit),)
|
65
|
|
- $(INSTALL_DIR) $(1)/etc/p11-kit/modules/
|
66
|
|
- $(CP) \
|
67
|
|
- ./files/opensc.module \
|
68
|
|
- $(1)/etc/p11-kit/modules/
|
69
|
|
-endif
|
70
|
|
-endef
|
71
|
|
-
|
72
|
|
-$(eval $(call BuildPackage,OpenSC))
|