소스 검색

python: use libncursesw instead of libncurses

Python's build scripts prefer ncursesw, and if it is detected
it will be used.
The problem will occur when linking, since ncursesw libs may not be
installed if not added as deps, but the sources will be compiled
against ncursesw.

Reference from Python's HISTORY file:
  Patch #1428494: Prefer linking against ncursesw over ncurses library.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Alexandru Ardelean 10 년 전
부모
커밋
820278a0c8
1개의 변경된 파일2개의 추가작업 그리고 2개의 파일을 삭제
  1. 2
    2
      lang/python/Makefile

+ 2
- 2
lang/python/Makefile 파일 보기

@@ -126,13 +126,13 @@ endef
126 126
 define Package/python-readline
127 127
 $(call Package/python/Default)
128 128
  TITLE:=Python support for readline
129
- DEPENDS:=@PACKAGE_python +PACKAGE_python:python +libreadline +libncurses @BROKEN
129
+ DEPENDS:=@PACKAGE_python +PACKAGE_python:python +libreadline +libncursesw @BROKEN
130 130
 endef
131 131
 
132 132
 define Package/python-ncurses
133 133
 $(call Package/python/Default)
134 134
  TITLE:=Python support for readline
135
- DEPENDS:=@PACKAGE_python +PACKAGE_python:python +libncurses
135
+ DEPENDS:=@PACKAGE_python +PACKAGE_python:python +libncursesw
136 136
 endef
137 137
 
138 138
 MAKE_FLAGS:=\