Browse Source

gstreamer1: reorganize options selection menus

gst-plugins-bad: plugins-bad package missing (fix install def)

Signed-off-by: Ted Hess <thess@kitschensync.net>
Ted Hess 10 years ago
parent
commit
8227368777

+ 58
- 14
multimedia/gst1-plugins-bad/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gst1-plugins-bad
11 11
 PKG_VERSION:=1.2.3
12
-PKG_RELEASE:=2
12
+PKG_RELEASE:=3
13 13
 
14 14
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
15 15
 
@@ -21,7 +21,7 @@ PKG_SOURCE:=gst-plugins-bad-$(PKG_VERSION).tar.xz
21 21
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-bad/
22 22
 PKG_MD5SUM:=cfd6f303c8df2740b27cc63b945decef
23 23
 
24
-PKG_BUILD_DEPENDS:= gstreamer1 gst1-plugins-base liboil
24
+PKG_BUILD_DEPENDS:= libgstreamer1 gstreamer1-plugins-base liboil
25 25
 
26 26
 PKG_FIXUP:=autoreconf
27 27
 PKG_INSTALL:=1
@@ -29,32 +29,70 @@ PKG_INSTALL:=1
29 29
 include $(INCLUDE_DIR)/package.mk
30 30
 include $(INCLUDE_DIR)/nls.mk
31 31
 
32
-define Package/gstreamer1/Default
32
+GST_BAD_LIBS:=
33
+GST_BAD_MODULES:=
34
+
35
+define Package/gstreamer1-bad/Default
33 36
   CATEGORY:=Multimedia
34 37
   SECTION:=multimedia
35 38
   TITLE:=GStreamer
36 39
   URL:=http://gstreamer.freedesktop.org/
37
-  DEPENDS:= $(ICONV_DEPENDS)
40
+  DEPENDS:= +libgstreamer1 $(ICONV_DEPENDS)
38 41
 endef
39 42
 
40
-define Package/gstreamer1/description/Default
43
+define Package/gstreamer1-bad/description/Default
41 44
  GStreamer open source multimedia framework
42 45
 endef
43 46
 
44 47
 
45 48
 define Package/gst1-plugins-bad
46
-$(call Package/gstreamer1/Default)
49
+$(call Package/gstreamer1-bad/Default)
47 50
   TITLE+= plugins collection (bad)
48 51
   DEPENDS+= $(GST_DEPENDS)
52
+  HIDDEN:=1
49 53
 endef
50 54
 
51 55
 define Package/gts1-plugins-bad/description
52
-$(call Package/gstreamer1/description/Default)
56
+$(call Package/gstreamer1-bad/description/Default)
53 57
  .
54 58
  This meta package contains only dependencies to the other plugins from
55 59
  the bad plugins collection.
56 60
 endef
57 61
 
62
+define Package/gstreamer1-plugins-bad
63
+  $(call Package/gstreamer1-bad/Default)
64
+  TITLE+= plugins collection (bad)
65
+  DEPENDS:=+ALL:gst1-plugins-bad +gstreamer1-plugins-base
66
+endef
67
+
68
+define Package/gstreamer1-plugins-bad/config
69
+    menu "Select GStreamer bad modules and libraries"
70
+      depends on PACKAGE_gstreamer1-plugins-bad
71
+
72
+
73
+    config gst1-plugins-bad-all
74
+      bool "Include all GStreamer bad plugins"
75
+      select PACKAGE_gst1-plugins-bad
76
+
77
+    comment "Modules"
78
+
79
+   $(foreach mod,$(GST_BAD_MODULES), \
80
+    config PACKAGE_gst1-mod-$(mod)
81
+      prompt "GStreamer $(mod) module"
82
+
83
+   )
84
+
85
+    comment "Libraries"
86
+
87
+   $(foreach lib,$(GST_BAD_LIBS), \
88
+    config PACKAGE_libgst1$(lib)
89
+      prompt "GStreamer $(lib) library"
90
+
91
+   )
92
+
93
+  endmenu
94
+
95
+endef
58 96
 
59 97
 GST_VERSION:=1.0
60 98
 
@@ -135,7 +173,7 @@ EXTRA_LDFLAGS+= \
135 173
 	$(if $(ICONV_FULL),-liconv) \
136 174
 
137 175
 
138
-define Package/gst1-plugins-ugly/install
176
+define Package/gst1-plugins-bad/install
139 177
 	/bin/true
140 178
 endef
141 179
 
@@ -147,14 +185,16 @@ define GstBuildLibrary
147 185
 
148 186
   GST_DEPENDS += +libgst1$(1)
149 187
 
188
+  GST_BAD_LIBS+= $(1)
150 189
   define Package/libgst1$(1)
151
-    $(call Package/gstreamer1/Default)
190
+    $(call Package/gstreamer1-bad/Default)
152 191
     TITLE+= $(2) library (base)
153
-    DEPENDS+= +libgstreamer1 $$(foreach p,$(3),+libgst1$$(p)) $(4)
192
+    DEPENDS+= $$(foreach p,$(3),+libgst1$$(p)) $(4)
193
+    HIDDEN:=1
154 194
   endef
155 195
 
156 196
   define Package/libgst1$(1)/description
157
-   $(call Package/gstreamer1/description/Default)
197
+   $(call Package/gstreamer1-bad/description/Default)
158 198
    .
159 199
    This package contains the GStreamer $(2) library.
160 200
   endef
@@ -182,14 +222,17 @@ define GstBuildPlugin
182 222
 
183 223
   GST_DEPENDS += +gst1-mod-$(1)
184 224
 
225
+  GST_BAD_MODULES+= $(1)
226
+
185 227
   define Package/gst1-mod-$(1)
186
-    $(call Package/gstreamer1/Default)
228
+    $(call Package/gstreamer1-bad/Default)
187 229
     TITLE+= $(2) plugin (bad)
188
-    DEPENDS+= +libgstreamer1 $$(foreach p,$(3),+libgst1$$(p)) $$(foreach p,$(4),+gst1-mod-$$(p)) $(5)
230
+    DEPENDS+= $$(foreach p,$(3),+libgst1$$(p)) $$(foreach p,$(4),+gst1-mod-$$(p)) $(5)
231
+    HIDDEN:=1
189 232
   endef
190 233
 
191 234
   define Package/gst1-mod-$(1)/description
192
-   $(call Package/gstreamer1/description/Default)
235
+   $(call Package/gstreamer1-bad/description/Default)
193 236
    .
194 237
    This package contains the GStreamer $(2) plugin.
195 238
   endef
@@ -235,4 +278,5 @@ $(eval $(call GstBuildPlugin,siren,siren support,audio rtp,,))
235 278
 $(eval $(call GstBuildPlugin,speed,speed support,audio,,))
236 279
 $(eval $(call GstBuildPlugin,subenc,subenc support,controller,,))
237 280
 
281
+$(eval $(call BuildPackage,gstreamer1-plugins-bad))
238 282
 $(eval $(call BuildPackage,gst1-plugins-bad))

+ 59
- 14
multimedia/gst1-plugins-base/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gst1-plugins-base
11 11
 PKG_VERSION:=1.2.3
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
15 15
 
@@ -21,7 +21,7 @@ PKG_SOURCE:=gst-plugins-base-$(PKG_VERSION).tar.xz
21 21
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-base/
22 22
 PKG_MD5SUM:=17aeabfbcd232526f50c9bee375f1b97
23 23
 
24
-PKG_BUILD_DEPENDS:= gstreamer1 liboil
24
+PKG_BUILD_DEPENDS:= libgstreamer1 liboil
25 25
 PKG_CONFIG_DEPENDS:= \
26 26
 	CONFIG_PACKAGE_gst1-mod-alsa \
27 27
 	CONFIG_PACKAGE_gst1-mod-app \
@@ -36,6 +36,7 @@ PKG_CONFIG_DEPENDS:= \
36 36
 	CONFIG_PACKAGE_gst1-mod-videotestsrc \
37 37
 	CONFIG_PACKAGE_gst1-mod-volume \
38 38
 	CONFIG_PACKAGE_gst1-mod-vorbis \
39
+	CONFIG_PACKAGE_libgst1app \
39 40
 
40 41
 PKG_FIXUP:=autoreconf
41 42
 PKG_INSTALL:=1
@@ -43,32 +44,70 @@ PKG_INSTALL:=1
43 44
 include $(INCLUDE_DIR)/package.mk
44 45
 include $(INCLUDE_DIR)/nls.mk
45 46
 
46
-define Package/gstreamer1/Default
47
+GST_BASE_LIBS:=
48
+GST_BASE_MODULES:=
49
+
50
+define Package/gstreamer1-base/Default
47 51
   CATEGORY:=Multimedia
48 52
   SECTION:=multimedia
49 53
   TITLE:=GStreamer
50 54
   URL:=http://gstreamer.freedesktop.org/
51
-  DEPENDS:= $(ICONV_DEPENDS)
55
+  DEPENDS:= +libgstreamer1 $(ICONV_DEPENDS)
52 56
 endef
53 57
 
54
-define Package/gstreamer1/description/Default
58
+define Package/gstreamer1-base/description/Default
55 59
  GStreamer open source multimedia framework
56 60
 endef
57 61
 
58 62
 
59 63
 define Package/gst1-plugins-base
60
-$(call Package/gstreamer1/Default)
64
+$(call Package/gstreamer1-base/Default)
61 65
   TITLE+= plugins collection (base)
62 66
   DEPENDS+= $(GST_DEPENDS)
67
+  HIDDEN:=1
63 68
 endef
64 69
 
65 70
 define Package/gts1-plugins-base/description
66
-$(call Package/gstreamer1/description/Default)
71
+$(call Package/gstreamer1-base/description/Default)
67 72
  .
68 73
  This meta package contains only dependencies to the other libraries and
69 74
  plugins from the base plugins collection.
70 75
 endef
71 76
 
77
+define Package/gstreamer1-plugins-base
78
+  $(call Package/gstreamer1-base/Default)
79
+  TITLE+= plugins collection (base)
80
+  DEPENDS:=+ALL:gst1-plugins-base +gstreamer1-libs
81
+endef
82
+
83
+define Package/gstreamer1-plugins-base/config
84
+    menu "Select GStreamer base modules and libraries"
85
+      depends on PACKAGE_gstreamer1-plugins-base
86
+
87
+
88
+    config gst1-plugins-base-all
89
+      bool "Include all GStreamer base plugins"
90
+      select PACKAGE_gst1-plugins-base
91
+
92
+    comment "Modules"
93
+
94
+   $(foreach mod,$(GST_BASE_MODULES), \
95
+    config PACKAGE_gst1-mod-$(mod)
96
+      prompt "GStreamer $(mod) module"
97
+
98
+   )
99
+
100
+    comment "Libraries"
101
+
102
+   $(foreach lib,$(GST_BASE_LIBS), \
103
+    config PACKAGE_libgst1$(lib)
104
+      prompt "GStreamer $(lib) library"
105
+
106
+   )
107
+
108
+  endmenu
109
+
110
+endef
72 111
 
73 112
 GST_COND_SELECT = $(patsubst %,$(if $(CONFIG_PACKAGE_gst1-mod-$(1)),--enable,--disable)-%,$(1))
74 113
 
@@ -156,14 +195,17 @@ define GstBuildLibrary
156 195
 
157 196
   GST_DEPENDS += +libgst1$(1)
158 197
 
198
+  GST_BASE_LIBS+= $(1)
199
+
159 200
   define Package/libgst1$(1)
160
-    $(call Package/gstreamer1/Default)
201
+    $(call Package/gstreamer1-base/Default)
161 202
     TITLE+= $(2) library (base)
162
-    DEPENDS+= +libgstreamer1 $$(foreach p,$(3),+libgst1$$(p)) $(4)
203
+    DEPENDS+= $$(foreach p,$(3),+libgst1$$(p)) $(4)
204
+    HIDDEN:=1
163 205
   endef
164 206
 
165 207
   define Package/libgst1$(1)/description
166
-   $(call Package/gstreamer1/description/Default)
208
+   $(call Package/gstreamer1-base/description/Default)
167 209
    .
168 210
    This package contains the GStreamer $(2) library.
169 211
   endef
@@ -190,7 +232,6 @@ $(eval $(call GstBuildLibrary,sdp,SDP,,))
190 232
 $(eval $(call GstBuildLibrary,tag,tag support,,))
191 233
 $(eval $(call GstBuildLibrary,video,video,,))
192 234
 
193
-
194 235
 # 1: short name
195 236
 # 2: description
196 237
 # 3: dependencies on other gstreamer libraries (short name)
@@ -200,14 +241,17 @@ define GstBuildPlugin
200 241
 
201 242
   GST_DEPENDS += +gst1-mod-$(1)
202 243
 
244
+  GST_BASE_MODULES+= $(1)
245
+
203 246
   define Package/gst1-mod-$(1)
204
-    $(call Package/gstreamer1/Default)
247
+    $(call Package/gstreamer1-base/Default)
205 248
     TITLE+= $(2) plugin (base)
206
-    DEPENDS+= +libgstreamer1 $$(foreach p,$(3),+libgst1$$(p)) $$(foreach p,$(4),+gst1-mod-$$(p)) $(5)
249
+    DEPENDS+= $$(foreach p,$(3),+libgst1$$(p)) $$(foreach p,$(4),+gst1-mod-$$(p)) $(5)
250
+    HIDDEN:=1
207 251
   endef
208 252
 
209 253
   define Package/gst1-mod-$(1)/description
210
-   $(call Package/gstreamer1/description/Default)
254
+   $(call Package/gstreamer1-base/description/Default)
211 255
    .
212 256
    This package contains the GStreamer $(2) plugin.
213 257
   endef
@@ -239,4 +283,5 @@ $(eval $(call GstBuildPlugin,videotestsrc,video test,video,,+liboil))
239 283
 $(eval $(call GstBuildPlugin,volume,volume,audio controller,,+liboil))
240 284
 $(eval $(call GstBuildPlugin,vorbis,Vorbis,audio tag,ogg,+libvorbis))
241 285
 
286
+$(eval $(call BuildPackage,gstreamer1-plugins-base))
242 287
 $(eval $(call BuildPackage,gst1-plugins-base))

+ 47
- 12
multimedia/gst1-plugins-good/Makefile View File

@@ -1,4 +1,5 @@
1
-## Copyright (C) 2009-2014 OpenWrt.org
1
+#
2
+# Copyright (C) 2009-2014 OpenWrt.org
2 3
 #
3 4
 # This is free software, licensed under the GNU General Public License v2.
4 5
 # See /LICENSE for more information.
@@ -8,7 +9,7 @@ include $(TOPDIR)/rules.mk
8 9
 
9 10
 PKG_NAME:=gst1-plugins-good
10 11
 PKG_VERSION:=1.2.3
11
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
12 13
 
13 14
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
14 15
 
@@ -20,7 +21,7 @@ PKG_SOURCE:=gst-plugins-good-$(PKG_VERSION).tar.xz
20 21
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-good/
21 22
 PKG_MD5SUM:=1a1f96bc27ad446e559474299160a9a8
22 23
 
23
-PKG_BUILD_DEPENDS:= gstreamer1 gst1-plugins-base liboil
24
+PKG_BUILD_DEPENDS:= libgstreamer1 gstreamer1-plugins-base liboil
24 25
 
25 26
 PKG_FIXUP:=autoreconf
26 27
 PKG_INSTALL:=1
@@ -28,33 +29,63 @@ PKG_INSTALL:=1
28 29
 include $(INCLUDE_DIR)/package.mk
29 30
 include $(INCLUDE_DIR)/nls.mk
30 31
 
31
-define Package/gstreamer1/Default
32
+GST_GOOD_MODULES:=
33
+
34
+define Package/gstreamer1-good/Default
32 35
   CATEGORY:=Multimedia
33 36
   SECTION:=multimedia
34 37
   TITLE:=GStreamer
35 38
   URL:=http://gstreamer.freedesktop.org/
36
-  DEPENDS:= $(ICONV_DEPENDS)
39
+  DEPENDS:= +libgstreamer1 $(ICONV_DEPENDS)
37 40
 endef
38 41
 
39
-define Package/gstreamer1/description/Default
42
+define Package/gstreamer1-good/description/Default
40 43
  GStreamer open source multimedia framework
41 44
 endef
42 45
 
43 46
 
44 47
 define Package/gst1-plugins-good
45
-$(call Package/gstreamer1/Default)
48
+$(call Package/gstreamer1-good/Default)
46 49
   TITLE+= plugins collection (good)
47 50
   DEPENDS+= $(GST_DEPENDS)
51
+  HIDDEN:=1
48 52
 endef
49 53
 
50
-define Package/gts-plugins-good/description
51
-$(call Package/gstreamer1/description/Default)
54
+define Package/gst1-plugins-good/description
55
+$(call Package/gstreamer1-good/description/Default)
52 56
  .
53 57
  This meta package contains only dependencies to the other plugins from
54 58
  the good plugins collection.
55 59
 endef
56 60
 
57 61
 
62
+define Package/gstreamer1-plugins-good
63
+  $(call Package/gstreamer1-good/Default)
64
+  TITLE+= plugins collection (good)
65
+  DEPENDS:=+ALL:gst1-plugins-good +gstreamer1-plugins-base
66
+endef
67
+
68
+define Package/gstreamer1-plugins-good/config
69
+    menu "Select GStreamer good modules"
70
+      depends on PACKAGE_gstreamer1-plugins-good
71
+
72
+
73
+    config gst1-plugins-good-all
74
+      bool "Include all GStreamer good plugins"
75
+      select PACKAGE_gst1-plugins-good
76
+
77
+    comment "Modules"
78
+
79
+   $(foreach mod,$(GST_GOOD_MODULES), \
80
+    config PACKAGE_gst1-mod-$(mod)
81
+      prompt "GStreamer $(mod) module"
82
+
83
+   )
84
+
85
+  endmenu
86
+
87
+endef
88
+
58 89
 GST_VERSION:=1.0
59 90
 
60 91
 CONFIGURE_ARGS += \
@@ -112,14 +143,17 @@ define GstBuildPlugin
112 143
 
113 144
   GST_DEPENDS += +gst1-mod-$(1)
114 145
 
146
+  GST_GOOD_MODULES+= $(1)
147
+
115 148
   define Package/gst1-mod-$(1)
116
-    $(call Package/gstreamer1/Default)
149
+    $(call Package/gstreamer1-good/Default)
117 150
     TITLE+= $(2) plugin (good)
118
-    DEPENDS+= +libgstreamer1 $$(foreach p,$(3),+libgst1$$(p)) $$(foreach p,$(4),+gst1-mod-$$(p)) $(5)
151
+    DEPENDS+= $$(foreach p,$(3),+libgst1$$(p)) $$(foreach p,$(4),+gst1-mod-$$(p)) $(5)
152
+    HIDDEN:=1
119 153
   endef
120 154
 
121 155
   define Package/gst1-mod-$(1)/description
122
-   $(call Package/gstreamer1/description/Default)
156
+   $(call Package/gstreamer1-good/description/Default)
123 157
    .
124 158
    This package contains the GStreamer $(2) plugin.
125 159
   endef
@@ -199,4 +233,5 @@ $(eval $(call GstBuildPlugin,wavenc,Wav encoder,riff,,))
199 233
 $(eval $(call GstBuildPlugin,wavparse,Wav parser,audio riff tag,,))
200 234
 #$(eval $(call GstBuildPlugin,ximagesrc,ximagesrc support,video,,))
201 235
 
236
+$(eval $(call BuildPackage,gstreamer1-plugins-good))
202 237
 $(eval $(call BuildPackage,gst1-plugins-good))

+ 43
- 9
multimedia/gst1-plugins-ugly/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gst1-plugins-ugly
11 11
 PKG_VERSION:=1.2.3
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
15 15
 
@@ -21,7 +21,7 @@ PKG_SOURCE:=gst-plugins-ugly-$(PKG_VERSION).tar.xz
21 21
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-ugly/
22 22
 PKG_MD5SUM:=7ae60e2f759f58f32af5fcdc3c9193c4
23 23
 
24
-PKG_BUILD_DEPENDS:= gstreamer1 gst1-plugins-base liboil
24
+PKG_BUILD_DEPENDS:= libgstreamer1 gstreamer1-plugins-base liboil
25 25
 PKG_CONFIG_DEPENDS:= \
26 26
 	CONFIG_PACKAGE_gst1-mod-asf \
27 27
 	CONFIG_PACKAGE_gst1-mod-lame \
@@ -34,33 +34,63 @@ PKG_INSTALL:=1
34 34
 include $(INCLUDE_DIR)/package.mk
35 35
 include $(INCLUDE_DIR)/nls.mk
36 36
 
37
-define Package/gstreamer1/Default
37
+GST_UGLY_MODULES:=
38
+
39
+define Package/gstreamer1-ugly/Default
38 40
   CATEGORY:=Multimedia
39 41
   SECTION:=multimedia
40 42
   TITLE:=GStreamer
41 43
   URL:=http://gstreamer.freedesktop.org/
42
-  DEPENDS:= $(ICONV_DEPENDS)
44
+  DEPENDS:= +libgstreamer1 $(ICONV_DEPENDS)
43 45
 endef
44 46
 
45
-define Package/gstreamer1/description/Default
47
+define Package/gstreamer1-ugly/description/Default
46 48
  GStreamer open source multimedia framework
47 49
 endef
48 50
 
49 51
 
50 52
 define Package/gst1-plugins-ugly
51
-$(call Package/gstreamer1/Default)
53
+$(call Package/gstreamer1-ugly/Default)
52 54
   TITLE+= plugins collection (ugly)
53 55
   DEPENDS+= $(GST_DEPENDS)
56
+  HIDDEN:=1
54 57
 endef
55 58
 
56 59
 define Package/gts-plugins-ugly/description
57
-$(call Package/gstreamer1/description/Default)
60
+$(call Package/gstreamer1-ugly/description/Default)
58 61
  .
59 62
  This meta package contains only dependencies to the other plugins from
60 63
  the ugly plugins collection.
61 64
 endef
62 65
 
63 66
 
67
+define Package/gstreamer1-plugins-ugly
68
+  $(call Package/gstreamer1-ugly/Default)
69
+  TITLE+= plugins collection (ugly)
70
+  DEPENDS:=+ALL:gst1-plugins-ugly +gstreamer1-plugins-base
71
+endef
72
+
73
+define Package/gstreamer1-plugins-ugly/config
74
+    menu "Select GStreamer ugly modules"
75
+      depends on PACKAGE_gstreamer1-plugins-ugly
76
+
77
+
78
+    config gst1-plugins-ugly-all
79
+      bool "Include all GStreamer ugly plugins"
80
+      select PACKAGE_gst1-plugins-ugly
81
+
82
+    comment "Modules"
83
+
84
+   $(foreach mod,$(GST_UGLY_MODULES), \
85
+    config PACKAGE_gst1-mod-$(mod)
86
+      prompt "GStreamer $(mod) module"
87
+
88
+   )
89
+
90
+  endmenu
91
+
92
+endef
93
+
64 94
 GST_COND_SELECT = $(patsubst %,$(if $(CONFIG_PACKAGE_gst1-mod-$(1)),--enable,--disable)-%,$(1))
65 95
 
66 96
 GST_VERSION:=1.0
@@ -111,14 +141,17 @@ define GstBuildPlugin
111 141
 
112 142
   GST_DEPENDS += +gst1-mod-$(1)
113 143
 
144
+  GST_UGLY_MODULES+= $(1)
145
+
114 146
   define Package/gst1-mod-$(1)
115
-    $(call Package/gstreamer1/Default)
147
+    $(call Package/gstreamer1-ugly/Default)
116 148
     TITLE+= $(2) plugin (ugly)
117 149
     DEPENDS+= +libgstreamer1 $$(foreach p,$(3),+libgst1$$(p)) $$(foreach p,$(4),+gst1-mod-$$(p)) $(5)
150
+    HIDDEN:=1
118 151
   endef
119 152
 
120 153
   define Package/gst1-mod-$(1)/description
121
-   $(call Package/gstreamer1/description/Default)
154
+   $(call Package/gstreamer1-ugly/description/Default)
122 155
    .
123 156
    This package contains the GStreamer $(2) plugin.
124 157
   endef
@@ -139,4 +172,5 @@ $(eval $(call GstBuildPlugin,lame,MP3 encoder (using LAME),audio,,+lame-lib))
139 172
 $(eval $(call GstBuildPlugin,mad,MP3 decoder (using MAD),audio tag,,+libid3tag +libmad))
140 173
 $(eval $(call GstBuildPlugin,mpeg2dec,MPEG decoder,video,,+libmpeg2))
141 174
 
175
+$(eval $(call BuildPackage,gstreamer1-plugins-ugly))
142 176
 $(eval $(call BuildPackage,gst1-plugins-ugly))

+ 50
- 17
multimedia/gstreamer1/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gstreamer1
11 11
 PKG_VERSION:=1.2.3
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
15 15
 
@@ -41,45 +41,73 @@ define Package/gstreamer1/description/Default
41 41
  GStreamer open source multimedia framework
42 42
 endef
43 43
 
44
+GSTREAMER_CORE_LIBS:= \
45
+	libgstreamer1 \
46
+	libgst1check \
47
+	libgst1controller \
48
+	libgst1net
44 49
 
45 50
 define Package/gstreamer1
46
-$(call Package/gstreamer1/Default)
47
-  TITLE+= framework
48
-  DEPENDS+= +libgstreamer1 \
49
-	+libgst1check \
50
-	+libgst1controller \
51
-	+libgst1net
51
+  $(call Package/gstreamer1/Default)
52
+  TITLE+= (All libraries)
53
+  DEPENDS:= $(foreach lib,$(GSTREAMER_CORE_LIBS),+$(lib))
54
+  HIDDEN:=1
52 55
 endef
53 56
 
54
-define Package/gstreamer1/description
55
-$(call Package/gstreamer1/description/Default)
57
+define Package/gstreamer1-libs/description
58
+ $(call Package/gstreamer1/description/Default)
56 59
  .
57 60
  This meta package contains only dependencies on the other GStreamer
58 61
  componenents.
59 62
 endef
60 63
 
64
+define Package/gstreamer1-libs
65
+  $(call Package/gstreamer1/Default)
66
+  TITLE+= core libraries
67
+  DEPENDS+=+ALL:gstreamer1
68
+endef
69
+
70
+define Package/gstreamer1-libs/config
71
+    menu "Select GStreamer libraries"
72
+      depends on PACKAGE_gstreamer1-libs
73
+
74
+    config gstreamer1-all
75
+      bool "Include all GStreamer1 core libraries"
76
+      select PACKAGE_gstreamer1
77
+
78
+    comment "Libraries"
79
+
80
+   $(foreach lib,$(GSTREAMER_CORE_LIBS), \
81
+    config PACKAGE_$(lib)
82
+      prompt "GStreamer core library $(lib)"
83
+
84
+   )
85
+
86
+  endmenu
87
+
88
+endef
61 89
 
62 90
 define Package/gstreamer1-utils
63
-$(call Package/gstreamer1/Default)
91
+  $(call Package/gstreamer1/Default)
64 92
   TITLE+= utilities
65
-  DEPENDS+= +libgstreamer1
93
+  DEPENDS+= +libgstreamer1 +gstreamer1-libs
66 94
 endef
67 95
 
68 96
 define Package/gstreamer1-utils/description
69
-$(call Package/gstreamer1/description/Default)
97
+ $(call Package/gstreamer1/description/Default)
70 98
  .
71 99
  This package contains the GStreamer utilities.
72 100
 endef
73 101
 
74
-
75 102
 define Package/libgstreamer1
76
-$(call Package/gstreamer1/Default)
103
+  $(call Package/gstreamer1/Default)
77 104
   TITLE+= library (core)
78 105
   DEPENDS+= +glib2 +libpthread +libxml2
106
+  HIDDEN:=1
79 107
 endef
80 108
 
81 109
 define Package/libgstreamer1/description
82
-$(call Package/gstreamer1/description/Default)
110
+ $(call Package/gstreamer1/description/Default)
83 111
  .
84 112
  This package contains the GStreamer core library.
85 113
 endef
@@ -129,7 +157,10 @@ define Build/InstallDev
129 157
 endef
130 158
 
131 159
 define Package/gstreamer1/install
132
-	/bin/true
160
+  true
161
+endef
162
+
163
+define Package/gstreamer1-libs/install
133 164
 endef
134 165
 
135 166
 define Package/gstreamer1-utils/install
@@ -167,6 +198,7 @@ define GstBuildLibrary
167 198
     $(call Package/gstreamer1/Default)
168 199
     TITLE+= $(2) library (core)
169 200
     DEPENDS+= +libgstreamer1 $$(foreach p,$(3),+libgst1$$(p)) $(4)
201
+    HIDDEN:=1
170 202
   endef
171 203
 
172 204
   define Package/libgst1$(1)/description
@@ -191,5 +223,6 @@ $(eval $(call GstBuildLibrary,controller,dynamic parameter control))
191 223
 $(eval $(call GstBuildLibrary,net,network classes))
192 224
 
193 225
 $(eval $(call BuildPackage,libgstreamer1))
194
-$(eval $(call BuildPackage,gstreamer1))
226
+$(eval $(call BuildPackage,gstreamer1-libs))
195 227
 $(eval $(call BuildPackage,gstreamer1-utils))
228
+$(eval $(call BuildPackage,gstreamer1))