Browse Source

libtorrent: remove manual autoconf invocation

The Makefile already uses the proper autoreconf fixup but leaves a manual
autoconf invocation in place.

The bad autoconf call leads to the following build error in the SDK:

	configure.ac:3: installing `./config.guess'
	configure.ac:3: installing `./config.sub'
	configure.ac:20: installing `./install-sh'
	configure.ac:20: installing `./missing'
	src/Makefile.am: installing `./depcomp'
	autoreconf: Leaving directory `.'
	aclocal...
	autoheader...
	libtoolize... libtoolize nor glibtoolize not found
	make[2]: *** [.../.configured_] Error 1

Remove the entire Build/Configure override to let libtorrent build correctly.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Jo-Philipp Wich 10 years ago
parent
commit
82927a24f9
1 changed files with 0 additions and 5 deletions
  1. 0
    5
      libs/libtorrent/Makefile

+ 0
- 5
libs/libtorrent/Makefile View File

@@ -51,11 +51,6 @@ CONFIGURE_ARGS+= \
51 51
 	--disable-instrumentation \
52 52
 	--with-zlib=$(STAGING_DIR)/usr
53 53
 
54
-define Build/Configure
55
-	( cd $(PKG_BUILD_DIR); ./autogen.sh );
56
-	$(call Build/Configure/Default)
57
-endef
58
-
59 54
 define Build/InstallDev
60 55
 	$(INSTALL_DIR) $(1)/usr/include
61 56
 	$(CP) $(PKG_INSTALL_DIR)/usr/include/torrent $(1)/usr/include/