瀏覽代碼

Merge pull request #1721 from dirkfeytons/master

strongswan: add a couple more plugins
Steven Barth 9 年之前
父節點
當前提交
82b53949a9
共有 1 個文件被更改,包括 14 次插入0 次删除
  1. 14
    0
      net/strongswan/Makefile

+ 14
- 0
net/strongswan/Makefile 查看文件

@@ -60,10 +60,13 @@ PKG_MOD_AVAILABLE:= \
60 60
 	pem \
61 61
 	pgp \
62 62
 	pkcs1 \
63
+	pkcs7 \
63 64
 	pkcs8 \
64 65
 	pkcs11 \
66
+	pkcs12 \
65 67
 	pubkey \
66 68
 	random \
69
+	rc2 \
67 70
 	resolve \
68 71
 	revocation \
69 72
 	sha1 \
@@ -73,6 +76,7 @@ PKG_MOD_AVAILABLE:= \
73 76
 	socket-dynamic \
74 77
 	sql \
75 78
 	sqlite \
79
+	sshkey \
76 80
 	stroke \
77 81
 	test-vectors \
78 82
 	unity \
@@ -170,10 +174,13 @@ $(call Package/strongswan/Default)
170 174
 	+strongswan-mod-pem \
171 175
 	+strongswan-mod-pgp \
172 176
 	+strongswan-mod-pkcs1 \
177
+	+strongswan-mod-pkcs7 \
173 178
 	+strongswan-mod-pkcs8 \
174 179
 	+strongswan-mod-pkcs11 \
180
+	+strongswan-mod-pkcs12 \
175 181
 	+strongswan-mod-pubkey \
176 182
 	+strongswan-mod-random \
183
+	+strongswan-mod-rc2 \
177 184
 	+strongswan-mod-resolve \
178 185
 	+strongswan-mod-revocation \
179 186
 	+strongswan-mod-sha1 \
@@ -182,6 +189,7 @@ $(call Package/strongswan/Default)
182 189
 	+strongswan-mod-socket-default \
183 190
 	+strongswan-mod-sql \
184 191
 	+strongswan-mod-sqlite \
192
+	+strongswan-mod-sshkey \
185 193
 	+strongswan-mod-stroke \
186 194
 	+strongswan-mod-test-vectors \
187 195
 	+strongswan-mod-uci \
@@ -226,11 +234,13 @@ $(call Package/strongswan/Default)
226 234
 	+strongswan-mod-pkcs1 \
227 235
 	+strongswan-mod-pubkey \
228 236
 	+strongswan-mod-random \
237
+	+strongswan-mod-rc2 \
229 238
 	+strongswan-mod-resolve \
230 239
 	+strongswan-mod-revocation \
231 240
 	+strongswan-mod-sha1 \
232 241
 	+strongswan-mod-sha2 \
233 242
 	+strongswan-mod-socket-default \
243
+	+strongswan-mod-sshkey \
234 244
 	+strongswan-mod-stroke \
235 245
 	+strongswan-mod-updown \
236 246
 	+strongswan-mod-x509 \
@@ -489,10 +499,13 @@ $(eval $(call BuildPlugin,openssl,OpenSSL crypto,+PACKAGE_strongswan-mod-openssl
489 499
 $(eval $(call BuildPlugin,pem,PEM decoding,))
490 500
 $(eval $(call BuildPlugin,pgp,PGP key decoding,))
491 501
 $(eval $(call BuildPlugin,pkcs1,PKCS1 key decoding,))
502
+$(eval $(call BuildPlugin,pkcs7,PKCS7 key decoding,))
492 503
 $(eval $(call BuildPlugin,pkcs8,PKCS8 key decoding,))
493 504
 $(eval $(call BuildPlugin,pkcs11,PKCS11 key decoding,))
505
+$(eval $(call BuildPlugin,pkcs12,PKCS12 key decoding,))
494 506
 $(eval $(call BuildPlugin,pubkey,raw public key,))
495 507
 $(eval $(call BuildPlugin,random,RNG,))
508
+$(eval $(call BuildPlugin,rc2,RC2 crypto,))
496 509
 $(eval $(call BuildPlugin,resolve,DNS resolver,))
497 510
 $(eval $(call BuildPlugin,revocation,X509 CRL/OCSP revocation,))
498 511
 $(eval $(call BuildPlugin,sha1,SHA1 crypto,))
@@ -502,6 +515,7 @@ $(eval $(call BuildPlugin,socket-default,default socket implementation for charo
502 515
 $(eval $(call BuildPlugin,socket-dynamic,dynamic socket implementation for charon,))
503 516
 $(eval $(call BuildPlugin,sql,SQL database interface,))
504 517
 $(eval $(call BuildPlugin,sqlite,SQLite database interface,+strongswan-mod-sql +PACKAGE_strongswan-mod-sqlite:libsqlite3))
518
+$(eval $(call BuildPlugin,sshkey,SSH key decoding,))
505 519
 $(eval $(call BuildPlugin,stroke,Stroke,+strongswan-utils))
506 520
 $(eval $(call BuildPlugin,test-vectors,crypto test vectors,))
507 521
 $(eval $(call BuildPlugin,uci,UCI config interface,+PACKAGE_strongswan-mod-uci:libuci))