Bladeren bron

Add gst1-plugins-base package

Signed-off-by: W. Michael Petullo <mike@flyn.org>
W. Michael Petullo 10 jaren geleden
bovenliggende
commit
8433800965

+ 238
- 0
multimedia/gst1-plugins-base/Makefile Bestand weergeven

@@ -0,0 +1,238 @@
1
+#
2
+# Copyright (C) 2008-2011 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=gst1-plugins-base
11
+PKG_VERSION:=1.2.3
12
+PKG_RELEASE:=1
13
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
14
+
15
+PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-base-$(PKG_VERSION)
16
+PKG_SOURCE:=gst-plugins-base-$(PKG_VERSION).tar.xz
17
+PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-base/
18
+PKG_MD5SUM:=17aeabfbcd232526f50c9bee375f1b97
19
+
20
+PKG_BUILD_DEPENDS:= gstreamer1 liboil
21
+PKG_CONFIG_DEPENDS:= \
22
+	CONFIG_PACKAGE_gst1-mod-alsa \
23
+	CONFIG_PACKAGE_gst1-mod-app \
24
+	CONFIG_PACKAGE_gst1-mod-audioconvert \
25
+	CONFIG_PACKAGE_gst1-mod-audiorate \
26
+	CONFIG_PACKAGE_gst1-mod-audioresample \
27
+	CONFIG_PACKAGE_gst1-mod-audiotestsrc \
28
+	CONFIG_PACKAGE_gst1-mod-gio \
29
+	CONFIG_PACKAGE_gst1-mod-ogg \
30
+	CONFIG_PACKAGE_gst1-mod-tcp \
31
+	CONFIG_PACKAGE_gst1-mod-theora \
32
+	CONFIG_PACKAGE_gst1-mod-videotestsrc \
33
+	CONFIG_PACKAGE_gst1-mod-volume \
34
+	CONFIG_PACKAGE_gst1-mod-vorbis \
35
+
36
+PKG_FIXUP:=autoreconf
37
+PKG_INSTALL:=1
38
+
39
+include $(INCLUDE_DIR)/package.mk
40
+include $(INCLUDE_DIR)/nls.mk
41
+
42
+# -liconv crept in from pkg-config, to be revisited later
43
+include $(INCLUDE_DIR)/nls.mk
44
+
45
+define Package/gstreamer1/Default
46
+  CATEGORY:=Multimedia
47
+  SECTION:=multimedia
48
+  TITLE:=GStreamer
49
+  URL:=http://gstreamer.freedesktop.org/
50
+endef
51
+
52
+define Package/gstreamer1/description/Default
53
+ GStreamer open source multimedia framework
54
+endef
55
+
56
+
57
+define Package/gst1-plugins-base
58
+$(call Package/gstreamer1/Default)
59
+  TITLE+= plugins collection (base)
60
+  DEPENDS+= $(GST_DEPENDS)
61
+endef
62
+
63
+define Package/gts1-plugins-base/description
64
+$(call Package/gstreamer1/description/Default)
65
+ .
66
+ This meta package contains only dependencies to the other libraries and
67
+ plugins from the base plugins collection.
68
+endef
69
+
70
+
71
+GST_COND_SELECT = $(patsubst %,$(if $(CONFIG_PACKAGE_gst1-mod-$(1)),--enable,--disable)-%,$(1))
72
+
73
+GST_VERSION:=1.0
74
+
75
+CONFIGURE_ARGS += \
76
+	--disable-debug \
77
+	--disable-examples \
78
+	\
79
+	$(call GST_COND_SELECT,alsa) \
80
+	--disable-alsa-test \
81
+	$(call GST_COND_SELECT,app) \
82
+	$(call GST_COND_SELECT,audioconvert) \
83
+	$(call GST_COND_SELECT,audiorate) \
84
+	$(call GST_COND_SELECT,audioresample) \
85
+	$(call GST_COND_SELECT,audiotestsrc) \
86
+	--disable-cdparanoia \
87
+	--disable-ffmpegcolorspace \
88
+	--disable-freetypetest \
89
+	$(call GST_COND_SELECT,gio) \
90
+	--disable-gnome_vfs \
91
+	--disable-gst_v4l \
92
+	--disable-libvisual \
93
+	$(call GST_COND_SELECT,ogg) \
94
+	--disable-oggtest \
95
+	--disable-pango \
96
+	--disable-subparse \
97
+	$(call GST_COND_SELECT,tcp) \
98
+	$(call GST_COND_SELECT,theora) \
99
+	--disable-videorate \
100
+	--disable-videoscale \
101
+	$(call GST_COND_SELECT,videotestsrc) \
102
+	$(call GST_COND_SELECT,volume) \
103
+	$(call GST_COND_SELECT,vorbis) \
104
+	--disable-vorbistest \
105
+	--disable-x \
106
+	--disable-xshm \
107
+	--disable-xvideo \
108
+	\
109
+	--without-libiconv-prefix \
110
+	--without-libintl-prefix \
111
+	--without-x \
112
+	\
113
+	--with-audioresample-format=int \
114
+
115
+EXTRA_LDFLAGS+= \
116
+	-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
117
+
118
+
119
+define Build/InstallDev
120
+	$(INSTALL_DIR) $(1)/usr/include/gstreamer-$(GST_VERSION)
121
+	( cd $(PKG_INSTALL_DIR); $(CP) \
122
+		./usr/include/gstreamer-$(GST_VERSION)/* \
123
+		$(1)/usr/include/gstreamer-$(GST_VERSION)/ \
124
+	)
125
+	$(INSTALL_DIR) $(1)/usr/lib
126
+	( cd $(PKG_INSTALL_DIR); $(CP) \
127
+		./usr/lib/libgst*-$(GST_VERSION).{la,so*} \
128
+		$(1)/usr/lib/ \
129
+	)
130
+	$(INSTALL_DIR) $(1)/usr/lib/gstreamer-$(GST_VERSION)
131
+	( cd $(PKG_INSTALL_DIR); $(CP) \
132
+		./usr/lib/gstreamer-$(GST_VERSION)/libgst*.{la,so} \
133
+		$(1)/usr/lib/gstreamer-$(GST_VERSION)/ \
134
+	)
135
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
136
+	( cd $(PKG_INSTALL_DIR); $(CP) \
137
+		./usr/lib/pkgconfig/gstreamer*-$(GST_VERSION).pc \
138
+		$(1)/usr/lib/pkgconfig/ \
139
+	)
140
+endef
141
+
142
+
143
+define Package/gst1-plugins-base/install
144
+	/bin/true
145
+endef
146
+
147
+
148
+# 1: short name
149
+# 2: description
150
+# 3: dependencies on other gstreamer libraries (short name)
151
+# 4: dependencies on other packages
152
+define GstBuildLibrary
153
+
154
+  GST_DEPENDS += +libgst1$(1)
155
+
156
+  define Package/libgst1$(1)
157
+    $(call Package/gstreamer1/Default)
158
+    TITLE+= $(2) library (base)
159
+    DEPENDS+= +libgstreamer1 $$(foreach p,$(3),+libgst1$$(p)) $(4)
160
+  endef
161
+
162
+  define Package/libgst1$(1)/description
163
+   $(call Package/gstreamer1/description/Default)
164
+   .
165
+   This package contains the GStreamer $(2) library.
166
+  endef
167
+
168
+  define Package/libgst1$(1)/install
169
+	$(INSTALL_DIR) $$(1)/usr/lib
170
+	( cd $(PKG_INSTALL_DIR); $(CP) \
171
+		./usr/lib/libgst$(1)-$(GST_VERSION).so.* \
172
+		$$(1)/usr/lib/ \
173
+	)
174
+  endef
175
+
176
+  $$(eval $$(call BuildPackage,libgst1$(1)))
177
+endef
178
+
179
+$(eval $(call GstBuildLibrary,app,app,,))
180
+$(eval $(call GstBuildLibrary,audio,audio,tag,))
181
+$(eval $(call GstBuildLibrary,fft,FFT,,))
182
+$(eval $(call GstBuildLibrary,pbutils,utils,audio tag video,))
183
+$(eval $(call GstBuildLibrary,riff,RIFF media,audio tag,,))
184
+$(eval $(call GstBuildLibrary,rtp,RTP,,))
185
+$(eval $(call GstBuildLibrary,rtsp,RTSP,,))
186
+$(eval $(call GstBuildLibrary,sdp,SDP,,))
187
+$(eval $(call GstBuildLibrary,tag,tag support,,))
188
+$(eval $(call GstBuildLibrary,video,video,,))
189
+
190
+
191
+# 1: short name
192
+# 2: description
193
+# 3: dependencies on other gstreamer libraries (short name)
194
+# 4: dependencies on other gstreamer plugins (short name)
195
+# 5: dependencies on other packages
196
+define GstBuildPlugin
197
+
198
+  GST_DEPENDS += +gst1-mod-$(1)
199
+
200
+  define Package/gst1-mod-$(1)
201
+    $(call Package/gstreamer1/Default)
202
+    TITLE+= $(2) plugin (base)
203
+    DEPENDS+= +libgstreamer1 $$(foreach p,$(3),+libgst1$$(p)) $$(foreach p,$(4),+gst1-mod-$$(p)) $(5)
204
+  endef
205
+
206
+  define Package/gst1-mod-$(1)/description
207
+   $(call Package/gstreamer1/description/Default)
208
+   .
209
+   This package contains the GStreamer $(2) plugin.
210
+  endef
211
+
212
+  define Package/gst1-mod-$(1)/install
213
+	$(INSTALL_DIR) $$(1)/usr/lib/gstreamer-$(GST_VERSION)
214
+	( cd $(PKG_INSTALL_DIR); $(CP) \
215
+		./usr/lib/gstreamer-$(GST_VERSION)/libgst$(1).so* \
216
+		$$(1)/usr/lib/gstreamer-$(GST_VERSION)/ \
217
+	)
218
+  endef
219
+
220
+  $$(eval $$(call BuildPackage,gst1-mod-$(1)))
221
+endef
222
+
223
+$(eval $(call GstBuildPlugin,alsa,ALSA,audio tag,,+alsa-lib))
224
+$(eval $(call GstBuildPlugin,app,app,app,,))
225
+$(eval $(call GstBuildPlugin,audioconvert,audio format conversion,audio,,))
226
+$(eval $(call GstBuildPlugin,audiorate,audio rate adjusting,audio tag,,))
227
+$(eval $(call GstBuildPlugin,audioresample,audio resampling,audio tag,,))
228
+$(eval $(call GstBuildPlugin,audiotestsrc,audio test,audio tag controller,,))
229
+$(eval $(call GstBuildPlugin,playback,media decoder (v2),pbutils,,))
230
+$(eval $(call GstBuildPlugin,gio,GIO,,,))
231
+$(eval $(call GstBuildPlugin,ogg,Ogg,riff tag pbutils video,,+libogg))
232
+$(eval $(call GstBuildPlugin,tcp,TCP,,,))
233
+$(eval $(call GstBuildPlugin,typefindfunctions,'typefind' functions,audio pbutils tag video,,))
234
+$(eval $(call GstBuildPlugin,videotestsrc,video test,video,,+liboil))
235
+$(eval $(call GstBuildPlugin,volume,volume,audio controller,,+liboil))
236
+$(eval $(call GstBuildPlugin,vorbis,Vorbis,audio tag,ogg,+libvorbis))
237
+
238
+$(eval $(call BuildPackage,gst1-plugins-base))

+ 36
- 0
multimedia/gst1-plugins-base/patches/001-no_docs.patch Bestand weergeven

@@ -0,0 +1,36 @@
1
+diff -u --recursive gst-plugins-base-1.0.7-vanilla/Makefile.am gst-plugins-base-1.0.7/Makefile.am
2
+--- gst-plugins-base-1.0.7-vanilla/Makefile.am	2013-06-01 22:38:30.495678685 -0500
3
++++ gst-plugins-base-1.0.7/Makefile.am	2013-06-01 22:39:04.374335121 -0500
4
+@@ -12,14 +12,12 @@
5
+ 	gst sys $(SUBDIRS_EXT) 	\
6
+ 	tools 			\
7
+ 	tests 			\
8
+-	docs			\
9
+ 	po 			\
10
+ 	common 			\
11
+ 	m4
12
+ 
13
+ DIST_SUBDIRS = 			\
14
+ 	pkgconfig		\
15
+-	docs			\
16
+ 	gst-libs		\
17
+ 	gst sys ext		\
18
+ 	tools 			\
19
+diff -u --recursive gst-plugins-base-1.0.7-vanilla/Makefile.in gst-plugins-base-1.0.7/Makefile.in
20
+--- gst-plugins-base-1.0.7-vanilla/Makefile.in	2013-06-01 22:38:30.527677416 -0500
21
++++ gst-plugins-base-1.0.7/Makefile.in	2013-06-01 22:38:59.110543873 -0500
22
+@@ -493,14 +493,12 @@
23
+ 	gst sys $(SUBDIRS_EXT) 	\
24
+ 	tools 			\
25
+ 	tests 			\
26
+-	docs			\
27
+ 	po 			\
28
+ 	common 			\
29
+ 	m4
30
+ 
31
+ DIST_SUBDIRS = \
32
+ 	pkgconfig		\
33
+-	docs			\
34
+ 	gst-libs		\
35
+ 	gst sys ext		\
36
+ 	tools 			\

+ 38
- 0
multimedia/gst1-plugins-base/patches/002-no_tests.patch Bestand weergeven

@@ -0,0 +1,38 @@
1
+diff -u --recursive gst-plugins-base-1.0.7-vanilla/Makefile.am gst-plugins-base-1.0.7/Makefile.am
2
+--- gst-plugins-base-1.0.7-vanilla/Makefile.am	2013-06-01 19:49:37.986260708 -0500
3
++++ gst-plugins-base-1.0.7/Makefile.am	2013-06-01 19:49:54.998590479 -0500
4
+@@ -11,7 +11,6 @@
5
+ 	gst-libs 		\
6
+ 	gst sys $(SUBDIRS_EXT) 	\
7
+ 	tools 			\
8
+-	tests 			\
9
+ 	po 			\
10
+ 	common 			\
11
+ 	m4
12
+@@ -21,7 +20,6 @@
13
+ 	gst-libs		\
14
+ 	gst sys ext		\
15
+ 	tools 			\
16
+-	tests 			\
17
+ 	po 			\
18
+ 	common 			\
19
+ 	m4
20
+diff -u --recursive gst-plugins-base-1.0.7-vanilla/Makefile.in gst-plugins-base-1.0.7/Makefile.in
21
+--- gst-plugins-base-1.0.7-vanilla/Makefile.in	2013-06-01 19:49:37.987260668 -0500
22
++++ gst-plugins-base-1.0.7/Makefile.in	2013-06-01 19:49:58.374457466 -0500
23
+@@ -492,7 +492,6 @@
24
+ 	gst-libs 		\
25
+ 	gst sys $(SUBDIRS_EXT) 	\
26
+ 	tools 			\
27
+-	tests 			\
28
+ 	po 			\
29
+ 	common 			\
30
+ 	m4
31
+@@ -502,7 +501,6 @@
32
+ 	gst-libs		\
33
+ 	gst sys ext		\
34
+ 	tools 			\
35
+-	tests 			\
36
+ 	po 			\
37
+ 	common 			\
38
+ 	m4

+ 49
- 0
multimedia/gst1-plugins-base/patches/003-no_translations.patch Bestand weergeven

@@ -0,0 +1,49 @@
1
+diff -u --recursive gst-plugins-base-1.0.7-vanilla/configure.ac gst-plugins-base-1.0.7/configure.ac
2
+--- gst-plugins-base-1.0.7-vanilla/configure.ac	2013-06-01 19:48:21.931257133 -0500
3
++++ gst-plugins-base-1.0.7/configure.ac	2013-06-01 19:51:30.371829534 -0500
4
+@@ -923,7 +923,6 @@
5
+ docs/libs/Makefile
6
+ docs/plugins/Makefile
7
+ docs/version.entities
8
+-po/Makefile.in
9
+ common/Makefile
10
+ common/m4/Makefile
11
+ m4/Makefile
12
+diff -u --recursive gst-plugins-base-1.0.7-vanilla/Makefile.am gst-plugins-base-1.0.7/Makefile.am
13
+--- gst-plugins-base-1.0.7-vanilla/Makefile.am	2013-06-01 19:50:30.232202309 -0500
14
++++ gst-plugins-base-1.0.7/Makefile.am	2013-06-01 19:50:58.973069965 -0500
15
+@@ -11,7 +11,6 @@
16
+ 	gst-libs 		\
17
+ 	gst sys $(SUBDIRS_EXT) 	\
18
+ 	tools 			\
19
+-	po 			\
20
+ 	common 			\
21
+ 	m4
22
+ 
23
+@@ -20,7 +19,6 @@
24
+ 	gst-libs		\
25
+ 	gst sys ext		\
26
+ 	tools 			\
27
+-	po 			\
28
+ 	common 			\
29
+ 	m4
30
+ 
31
+diff -u --recursive gst-plugins-base-1.0.7-vanilla/Makefile.in gst-plugins-base-1.0.7/Makefile.in
32
+--- gst-plugins-base-1.0.7-vanilla/Makefile.in	2013-06-01 19:50:30.233202273 -0500
33
++++ gst-plugins-base-1.0.7/Makefile.in	2013-06-01 19:51:22.796130711 -0500
34
+@@ -492,7 +492,6 @@
35
+ 	gst-libs 		\
36
+ 	gst sys $(SUBDIRS_EXT) 	\
37
+ 	tools 			\
38
+-	po 			\
39
+ 	common 			\
40
+ 	m4
41
+ 
42
+@@ -501,7 +500,6 @@
43
+ 	gst-libs		\
44
+ 	gst sys ext		\
45
+ 	tools 			\
46
+-	po 			\
47
+ 	common 			\
48
+ 	m4
49
+