Browse Source

ruby: fix ruby/host build

  - build ruby/host extensions as static,
  - remove dependency on gmp/host

Signed-off-by: Nicolas Thill <nico@openwrt.org>
Nicolas Thill 10 years ago
parent
commit
84c04a73e6
1 changed files with 2 additions and 3 deletions
  1. 2
    3
      lang/ruby/Makefile

+ 2
- 3
lang/ruby/Makefile View File

@@ -32,8 +32,6 @@ PKG_INSTALL:=1
32 32
 PKG_BUILD_PARALLEL:=1
33 33
 PKG_FIXUP:=autoreconf
34 34
 
35
-HOST_BUILD_DEPENDS:=gmp/host
36
-
37 35
 include $(INCLUDE_DIR)/host-build.mk
38 36
 include $(INCLUDE_DIR)/package.mk
39 37
 include $(INCLUDE_DIR)/nls.mk
@@ -210,7 +208,8 @@ endef
210 208
 HOST_CONFIGURE_ARGS += \
211 209
 	--disable-install-doc \
212 210
 	--disable-install-rdoc \
213
-	--disable-install-capi
211
+	--disable-install-capi \
212
+	--with-static-linked-ext \
214 213
 
215 214
 CONFIGURE_ARGS += \
216 215
 	--enable-shared \