Browse Source

ncdu: update to 1.11

- Add patch to get WEXITSTATUS and WIFEXITED defined
    The issue is fixed in upstream's development repo, so the patch won't be
    needed with ncdu's next release.
- Depend on more commonly used libncurses instead of libncursesw
- Enable parallel build
- Update copyright

Signed-off-by: Charles Lehner <cel@celehner.com>
Charles Lehner 9 years ago
parent
commit
851c9c9da7
2 changed files with 17 additions and 4 deletions
  1. 7
    4
      utils/ncdu/Makefile
  2. 10
    0
      utils/ncdu/patches/010-add_sys_wait.patch

+ 7
- 4
utils/ncdu/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2014 OpenWrt.org
2
+# Copyright (C) 2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -8,14 +8,15 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=ncdu
11
-PKG_VERSION:=1.10
11
+PKG_VERSION:=1.11
12 12
 PKG_RELEASE=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://dev.yorhel.nl/download
16
-PKG_MD5SUM:=7535decc8d54eca811493e82d4bfab2d
16
+PKG_MD5SUM:=9e44240a5356b029f05f0e70a63c4d12
17 17
 
18 18
 PKG_INSTALL:=1
19
+PKG_BUILD_PARALLEL:=1
19 20
 
20 21
 PKG_LICENSE:=MIT
21 22
 PKG_LICENSE_FILES:=COPYING
@@ -26,7 +27,7 @@ define Package/ncdu
26 27
   SUBMENU:=Filesystem
27 28
   SECTION:=utils
28 29
   CATEGORY:=Utilities
29
-  DEPENDS:=+libncursesw
30
+  DEPENDS:=+libncurses
30 31
   TITLE:=ncurses disk usage viewer
31 32
   MAINTAINER:=Charles Lehner <celehner1@gmail.com>
32 33
   URL:=http://dev.yorhel.nl/ncdu
@@ -38,6 +39,8 @@ define Package/ncdu/description
38 39
   directories and show percentages of disk usage with ncurses library.
39 40
 endef
40 41
 
42
+CONFIGURE_ARGS += --with-ncurses
43
+
41 44
 define Package/ncdu/install
42 45
 	$(INSTALL_DIR) $(1)/usr/bin
43 46
 	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ncdu $(1)/usr/bin/

+ 10
- 0
utils/ncdu/patches/010-add_sys_wait.patch View File

@@ -0,0 +1,10 @@
1
+--- a/src/shell.c
2
++++ b/src/shell.c
3
+@@ -33,6 +33,7 @@
4
+ #include <stdlib.h>
5
+ #include <unistd.h>
6
++#include <sys/wait.h>
7
+ 
8
+ void shell_draw() {
9
+   char *full_path;
10
+   int res;