|
@@ -0,0 +1,54 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2006-2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=luarocks
|
|
11
|
+PKG_VERSION:=2.2.0-rc1
|
|
12
|
+PKG_RELEASE:=2
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=v$(PKG_VERSION).tar.gz
|
|
15
|
+PKG_SOURCE_URL:=https://github.com/keplerproject/$(PKG_NAME)/archive/
|
|
16
|
+PKG_MAINTAINER:=Amr Hassan <amr.hassan@gmail.com>
|
|
17
|
+PKG_INSTALL=1
|
|
18
|
+PKG_BUILD_DEPENDS:=lua/host luac/host
|
|
19
|
+PKG_LICENSE=GPL
|
|
20
|
+
|
|
21
|
+include $(INCLUDE_DIR)/package.mk
|
|
22
|
+
|
|
23
|
+define Package/luarocks
|
|
24
|
+ SUBMENU:=Lua
|
|
25
|
+ SECTION:=lang
|
|
26
|
+ CATEGORY:=Languages
|
|
27
|
+ TITLE:=luarocks
|
|
28
|
+ URL:=https://github.com/keplerproject/luarocks
|
|
29
|
+ DEPENDS:=+lua +luac +liblua +luasocket +unzip +curl +luasec
|
|
30
|
+endef
|
|
31
|
+
|
|
32
|
+define Package/luarocks/description
|
|
33
|
+ LuaRocks is a deployment and management system for Lua modules.
|
|
34
|
+endef
|
|
35
|
+
|
|
36
|
+# My custom args, copied and modified from SDK_ROOT/include/package-defaults.mk
|
|
37
|
+CONFIGURE_ARGS = \
|
|
38
|
+ --prefix=$(CONFIGURE_PREFIX) \
|
|
39
|
+ --sysconfdir=/etc \
|
|
40
|
+ --with-lua=$(STAGING_DIR_HOST)
|
|
41
|
+
|
|
42
|
+define Build/Compile
|
|
43
|
+ $(call Build/Compile/Default,build)
|
|
44
|
+endef
|
|
45
|
+
|
|
46
|
+define Package/luarocks/install
|
|
47
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
48
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/luarocks-5.1 $(1)/usr/bin/luarocks
|
|
49
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/luarocks-admin-5.1 $(1)/usr/bin/luarocks-admin
|
|
50
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/share $(1)/usr/share
|
|
51
|
+ $(CP) $(PKG_INSTALL_DIR)/etc $(1)/etc
|
|
52
|
+endef
|
|
53
|
+
|
|
54
|
+$(eval $(call BuildPackage,luarocks))
|