Browse Source

haproxy: update to version 1.5.11 and pending patches

     - BUG/MEDIUM: backend: correctly detect the domain when use_domain_only is used
     - MINOR: ssl: load certificates in alphabetical order
     - BUG/MINOR: checks: prevent http keep-alive with http-check expect
     - BUG/MEDIUM: Do not set agent health to zero if server is disabled in config
     - MEDIUM/BUG: Only explicitly report "DOWN (agent)" if the agent health is zero
     - BUG/MINOR: stats:Fix incorrect printf type.
     - DOC: add missing entry for log-format and clarify the text
     - BUG/MEDIUM: http: fix header removal when previous header ends with pure LF
     - BUG/MEDIUM: channel: fix possible integer overflow on reserved size computation
     - BUG/MINOR: channel: compare to_forward with buf->i, not buf->size
     - MINOR: channel: add channel_in_transit()
     - MEDIUM: channel: make buffer_reserved() use channel_in_transit()
     - MEDIUM: channel: make bi_avail() use channel_in_transit()
     - BUG/MEDIUM: channel: don't schedule data in transit for leaving until connected
     - BUG/MAJOR: log: don't try to emit a log if no logger is set
     - BUG/MINOR: args: add missing entry for ARGT_MAP in arg_type_names
     - BUG/MEDIUM: http: make http-request set-header compute the string before removal
     - BUG/MINOR: http: fix incorrect header value offset in replace-hdr/replace-value
     - BUG/MINOR: http: abort request processing on filter failure
     - BUG/MINOR: pattern: error message missing
     - BUG/MEDIUM: pattern: some entries are not deleted with case insensitive match

Signed-off-by: Thomas Heil <heil@terminal-consulting.de>
Thomas Heil 10 years ago
parent
commit
8609cc44e7

+ 3
- 3
net/haproxy/Makefile View File

@@ -9,12 +9,12 @@
9 9
 include $(TOPDIR)/rules.mk
10 10
 
11 11
 PKG_NAME:=haproxy
12
-PKG_VERSION:=1.5.10
13
-PKG_RELEASE:=00
12
+PKG_VERSION:=1.5.11
13
+PKG_RELEASE:=02
14 14
 PKG_SOURCE:=haproxy-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://haproxy.1wt.eu/download/1.5/src/
16 16
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
17
-PKG_MD5SUM:=5631457ea1f84b3c0d8e5bc8015ed329
17
+PKG_MD5SUM:=5500a79d0d2b238d4a1e9749bd0c2cb2
18 18
 PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>
19 19
 PKG_LICENSE:=GPL-2.0
20 20
 

+ 30
- 0
net/haproxy/patches/0001-BUG-MINOR-pattern-error-message-missing.patch View File

@@ -0,0 +1,30 @@
1
+From e338a8741983acc9a4501a03ecd593d89e6fade3 Mon Sep 17 00:00:00 2001
2
+From: Thierry FOURNIER <tfournier@exceliance.fr>
3
+Date: Fri, 6 Feb 2015 17:50:55 +0100
4
+Subject: [PATCH 1/2] BUG/MINOR: pattern: error message missing
5
+
6
+This patch must be backported in 1.5 version.
7
+(cherry picked from commit 8aa8384e22dd0b66ded00c70a9c6034278b4bb69)
8
+---
9
+ src/pattern.c | 4 +++-
10
+ 1 file changed, 3 insertions(+), 1 deletion(-)
11
+
12
+diff --git a/src/pattern.c b/src/pattern.c
13
+index 208e33a..a6fc52d 100644
14
+--- a/src/pattern.c
15
++++ b/src/pattern.c
16
+@@ -989,8 +989,10 @@ int pat_idx_list_ptr(struct pattern_expr *expr, struct pattern *pat, char **err)
17
+ 
18
+ 	/* allocate pattern */
19
+ 	patl = calloc(1, sizeof(*patl));
20
+-	if (!patl)
21
++	if (!patl) {
22
++		memprintf(err, "out of memory while indexing pattern");
23
+ 		return 0;
24
++	}
25
+ 
26
+ 	/* duplicate pattern */
27
+ 	memcpy(&patl->pat, pat, sizeof(*pat));
28
+-- 
29
+2.0.4
30
+

+ 38
- 0
net/haproxy/patches/0002-BUG-MEDIUM-pattern-some-entries-are-not-deleted-with.patch View File

@@ -0,0 +1,38 @@
1
+From 623401b983185c1e0f6507e96557de3bc46fd41b Mon Sep 17 00:00:00 2001
2
+From: Thierry FOURNIER <tfournier@exceliance.fr>
3
+Date: Fri, 6 Feb 2015 17:53:54 +0100
4
+Subject: [PATCH 2/2] BUG/MEDIUM: pattern: some entries are not deleted with
5
+ case insensitive match
6
+
7
+ACL or map entries are not deleted with the command "del acl" or "del map"
8
+if the case insentive flag is set.
9
+
10
+This is because the the case insensitive string are stored in a list and the
11
+default delete function associated with string looks in a tree. I add a check
12
+of the case insensitive flag and execute the delete function for lists if it
13
+is set.
14
+
15
+This patch must be backported in 1.5 version.
16
+(cherry picked from commit 73bc285be194f443dc7eab9c949e87e1dbe8f70c)
17
+---
18
+ src/pattern.c | 4 ++++
19
+ 1 file changed, 4 insertions(+)
20
+
21
+diff --git a/src/pattern.c b/src/pattern.c
22
+index a6fc52d..b19ffe2 100644
23
+--- a/src/pattern.c
24
++++ b/src/pattern.c
25
+@@ -1308,6 +1308,10 @@ void pat_del_tree_str(struct pattern_expr *expr, struct pat_ref_elt *ref)
26
+ 	struct ebmb_node *node, *next_node;
27
+ 	struct pattern_tree *elt;
28
+ 
29
++	/* If the flag PAT_F_IGNORE_CASE is set, we cannot use trees */
30
++	if (expr->mflags & PAT_MF_IGNORE_CASE)
31
++		return pat_del_list_ptr(expr, ref);
32
++
33
+ 	/* browse each node of the tree. */
34
+ 	for (node = ebmb_first(&expr->pattern_tree), next_node = node ? ebmb_next(node) : NULL;
35
+ 	     node;
36
+-- 
37
+2.0.4
38
+