瀏覽代碼

unrar: Import 4.0.7 from packages and update to 5.1.6.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Álvaro Fernández Rojas 10 年之前
父節點
當前提交
864f5d8865
共有 2 個檔案被更改,包括 69 行新增0 行删除
  1. 50
    0
      utils/unrar/Makefile
  2. 19
    0
      utils/unrar/patches/100-makefile_fixes.patch

+ 50
- 0
utils/unrar/Makefile 查看文件

@@ -0,0 +1,50 @@
1
+#
2
+# Copyright (C) 2006-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=unrar
11
+PKG_VERSION:=5.1.6
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=unrarsrc-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=http://www.rarlab.com/rar
16
+PKG_MD5SUM:=be9607c59d62c3b101a70cd62c681515
17
+PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
18
+
19
+PKG_LICENSE:=UnRAR
20
+PKG_LICENSE_FILES:=license.txt
21
+
22
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/unrar
23
+PKG_INSTALL:=1
24
+
25
+include $(INCLUDE_DIR)/uclibc++.mk
26
+include $(INCLUDE_DIR)/package.mk
27
+
28
+define Package/unrar
29
+  SECTION:=utils
30
+  CATEGORY:=Utilities
31
+  SUBMENU:=Compression
32
+  TITLE:=UnRAR application
33
+  URL:=http://www.rarlab.com/
34
+  DEPENDS:=$(CXX_DEPENDS) +libpthread
35
+endef
36
+
37
+define Package/unrar/description
38
+   UnRAR is an application that can decompress files and archives created using
39
+   the RAR compression scheme
40
+endef
41
+
42
+define Build/Configure
43
+endef
44
+
45
+define Package/unrar/install
46
+	$(INSTALL_DIR) $(1)/usr/bin
47
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/unrar $(1)/usr/bin/
48
+endef
49
+
50
+$(eval $(call BuildPackage,unrar))

+ 19
- 0
utils/unrar/patches/100-makefile_fixes.patch 查看文件

@@ -0,0 +1,19 @@
1
+diff -uprN a/unrar/makefile b/unrar/makefile
2
+--- a/makefile	2014-06-12 13:36:14.723816266 +0200
3
++++ b/makefile	2014-06-12 13:36:36.174531961 +0200
4
+@@ -2,12 +2,12 @@
5
+ # Makefile for UNIX - unrar
6
+ 
7
+ # Linux using GCC
8
+-CXX=g++
9
+-CXXFLAGS=-O2
10
++#CXX=g++
11
++#CXXFLAGS=-O2
12
+ LIBFLAGS=-fPIC
13
+ DEFINES=-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DRAR_SMP
14
+ STRIP=strip
15
+-LDFLAGS=-pthread
16
++LDFLAGS=-lpthread
17
+ DESTDIR=/usr
18
+ 
19
+ # Linux using LCC