Переглянути джерело

libmpdclient: Update to 2.10

Signed-off-by: Ted Hess <thess@kitschensync.net>
Ted Hess 9 роки тому
джерело
коміт
86668ddea4

+ 3
- 3
libs/libmpdclient/Makefile Переглянути файл

@@ -8,12 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=libmpdclient
11
-PKG_VERSION:=2.9
12
-PKG_RELEASE:=3
11
+PKG_VERSION:=2.10
12
+PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
15 15
 PKG_SOURCE_URL:=http://www.musicpd.org/download/libmpdclient/2/
16
-PGK_MD5SUM:=4b101a36e5c0cf967dc063391260ddbf
16
+PGK_MD5SUM:=00606c630b905aa6196330373b366c29
17 17
 
18 18
 PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
19 19
 PKG_LICENSE:=BSD-3-Clause

+ 0
- 22
libs/libmpdclient/patches/001-WIP_musl_compatibility.patch Переглянути файл

@@ -1,22 +0,0 @@
1
---- a/src/socket.c
2
-+++ b/src/socket.c
3
-@@ -43,6 +43,7 @@
4
- #else
5
- #  include <netinet/in.h>
6
- #  include <arpa/inet.h>
7
-+#  include <sys/select.h>
8
- #  include <sys/socket.h>
9
- #  include <netdb.h>
10
- #  include <sys/un.h>
11
---- a/src/sync.c
12
-+++ b/src/sync.c
13
-@@ -33,6 +33,9 @@
14
- #include <assert.h>
15
- #include <stdlib.h>
16
- #include <stdio.h>
17
-+#ifndef WIN32
18
-+#include <sys/select.h>
19
-+#endif
20
- #include <fcntl.h>
21
- #include <unistd.h>
22
-