|
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
|
11
|
11
|
|
12
|
12
|
PKG_NAME:=zeromq
|
13
|
13
|
PKG_VERSION:=4.0.5
|
14
|
|
-PKG_RELEASE:=1
|
|
14
|
+PKG_RELEASE:=2
|
15
|
15
|
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
|
16
|
16
|
PKG_LICENSE:=GPL-3.0+
|
17
|
17
|
PKG_LICENSE_FILES:=LICENCE.txt
|
|
@@ -31,28 +31,26 @@ PKG_INSTALL:=1
|
31
|
31
|
include $(INCLUDE_DIR)/uclibc++.mk
|
32
|
32
|
include $(INCLUDE_DIR)/package.mk
|
33
|
33
|
|
34
|
|
-define Package/libzmq/Default
|
35
|
|
- TITLE:=ZeroMQ - Code Connected
|
36
|
|
- URL:=http://www.zeromq.org/
|
37
|
|
-endef
|
38
|
|
-
|
39
|
|
-define Package/libzmq/Default/description
|
40
|
|
- A replacment for raw socket developing library
|
41
|
|
-endef
|
42
|
|
-
|
43
|
34
|
define Package/libzmq
|
44
|
|
- $(call Package/libzmq/Default)
|
|
35
|
+ TITLE:=ZeroMQ - Message Queue engine
|
|
36
|
+ URL:=http://www.zeromq.org/
|
45
|
37
|
SECTION:=libs
|
46
|
38
|
CATEGORY:=Libraries
|
47
|
|
- DEPENDS:=+libuuid +libpthread +librt +libsodium $(CXX_DEPENDS)
|
48
|
|
- TITLE+= (library)
|
49
|
|
- URL:=
|
|
39
|
+ DEPENDS:=+libuuid +libpthread +librt +PACKAGE_libsodium:libsodium $(CXX_DEPENDS)
|
|
40
|
+ MENU:=1
|
|
41
|
+endef
|
|
42
|
+
|
|
43
|
+define Package/libzmq/config
|
|
44
|
+ config LIBZMQ_CURVEZMQ
|
|
45
|
+ bool "Include support for CurveZMQ security"
|
|
46
|
+ depends on PACKAGE_libzmq
|
|
47
|
+ default y
|
|
48
|
+ select PACKAGE_libsodium
|
50
|
49
|
endef
|
51
|
50
|
|
52
|
51
|
define Package/libzmq/description
|
53
|
|
- $(call Package/libzmq/Default/description)
|
54
|
|
- This package contains the ZeroMQ shared library, used by other
|
55
|
|
- programs.
|
|
52
|
+ This package contains the ZeroMQ messaging engine shared library.
|
|
53
|
+ CurveZMQ security protocols are optional using libsodium.
|
56
|
54
|
endef
|
57
|
55
|
|
58
|
56
|
# add extra configure flags here
|