Browse Source

Merge pull request #40 from heil/master

haproxy: add upstream bugfix, adapt Copyright
sbyx 10 years ago
parent
commit
87d5136edf

+ 2
- 2
net/haproxy/Makefile View File

@@ -1,6 +1,6 @@
1 1
 #
2 2
 # Copyright (C) 2010-2013 OpenWrt.org
3
-# Copyright (C) 2009-2013 Thomas Heil <heil@terminal-consulting.de>
3
+# Copyright (C) 2009-2014 Thomas Heil <heil@terminal-consulting.de>
4 4
 #
5 5
 # This is free software, licensed under the GNU General Public License v2.
6 6
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
10 10
 
11 11
 PKG_NAME:=haproxy
12 12
 PKG_VERSION:=1.5.0
13
-PKG_RELEASE:=00
13
+PKG_RELEASE:=01
14 14
 PKG_SOURCE:=haproxy-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://haproxy.1wt.eu/download/1.5/src/
16 16
 PKG_MD5SUM:=e33bb97e644e98af948090f1ecebbda9

+ 31
- 0
net/haproxy/patches/0001-BUG-MEDIUM-Consistently-use-check-in-process_chk.patch View File

@@ -0,0 +1,31 @@
1
+From 9ac7cabaf9945fb92c96cb92f5ea85235f54f7d6 Mon Sep 17 00:00:00 2001
2
+From: Simon Horman <horms@verge.net.au>
3
+Date: Fri, 20 Jun 2014 12:29:47 +0900
4
+Subject: [PATCH] BUG/MEDIUM: Consistently use 'check' in process_chk
5
+
6
+I am not entirely sure that this is a bug, but it seems
7
+to me that it may cause a problem if there agent-check is
8
+configured and there is some kind of error making a connection for it.
9
+
10
+Signed-off-by: Simon Horman <horms@verge.net.au>
11
+(cherry picked from commit ccaabcdfca23851af6fd83f4f3265284d283e2ab)
12
+---
13
+ src/checks.c | 2 +-
14
+ 1 file changed, 1 insertion(+), 1 deletion(-)
15
+
16
+diff --git a/src/checks.c b/src/checks.c
17
+index cba0018..f3b2b54 100644
18
+--- a/src/checks.c
19
++++ b/src/checks.c
20
+@@ -1541,7 +1541,7 @@ static struct task *process_chk(struct task *t)
21
+ 		 * First, let's check whether there was an uncaught error,
22
+ 		 * which can happen on connect timeout or error.
23
+ 		 */
24
+-		if (s->check.result == CHK_RES_UNKNOWN) {
25
++		if (check->result == CHK_RES_UNKNOWN) {
26
+ 			/* good connection is enough for pure TCP check */
27
+ 			if ((conn->flags & CO_FL_CONNECTED) && !check->type) {
28
+ 				if (check->use_ssl)
29
+-- 
30
+1.8.5.5
31
+