Sfoglia il codice sorgente

ibrdtnd: Add patch to exclude build of documentation using pdflatex

By default the package detects the presence of pdflatex and builds documentation automatically.
During the OpenWrt build this behavior is not acceptable. The added patch introduces a configure
option to explicitly enable the build of the documentation on request.

Signed-off-by: Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
Johannes Morgenroth 10 anni fa
parent
commit
896951b852
1 ha cambiato i file con 26 aggiunte e 0 eliminazioni
  1. 26
    0
      net/ibrdtnd/patches/110-add_configure_options_docs.patch

+ 26
- 0
net/ibrdtnd/patches/110-add_configure_options_docs.patch Vedi File

@@ -0,0 +1,26 @@
1
+--- a/configure.ac
2
++++ b/configure.ac
3
+@@ -138,11 +138,17 @@ AS_IF([test "x$enable_android" = "xyes"], [
4
+ 	# Checks for library functions.
5
+ 	AC_CHECK_FUNCS([gethostname socket])
6
+ 
7
+-	# Check for presence of pdfLaTeX
8
+-	AC_CHECK_PROG(PDFLATEX, pdflatex, pdflatex)
9
+-	if test -z "$PDFLATEX"; then
10
+-	AC_MSG_WARN([Unable to create PDF version of the documentation.])
11
+-	fi
12
++	AC_ARG_ENABLE([docs],
13
++		AS_HELP_STRING([--enable-docs], [Build documentation using PDFLaTeX]),
14
++	[
15
++		# Check for presence of pdfLaTeX
16
++		AC_CHECK_PROG(PDFLATEX, pdflatex, pdflatex)
17
++		if test -z "$PDFLATEX"; then
18
++			AC_MSG_WARN([Unable to create PDF version of the documentation.])
19
++		fi
20
++	], [
21
++		PDFLATEX="no"
22
++	])
23
+ 
24
+ 	AC_ARG_ENABLE([libdaemon],
25
+ 		AS_HELP_STRING([--disable-libdaemon], [Build without libdaemon support]),
26
+--