|
@@ -0,0 +1,41 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=m4
|
|
11
|
+PKG_VERSION:=1.4.17
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE_URL:=@GNU/m4
|
|
15
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
16
|
+PKG_MD5SUM:=a5e9954b1dae036762f7b13673a2cf76
|
|
17
|
+PKG_MAINTAINER:=Heinrich Schuchardt <xypron.glpk@gmx.de>
|
|
18
|
+PKG_LICENSE:=GPL-3.0+
|
|
19
|
+
|
|
20
|
+PKG_INSTALL:=1
|
|
21
|
+
|
|
22
|
+include $(INCLUDE_DIR)/package.mk
|
|
23
|
+
|
|
24
|
+define Package/m4
|
|
25
|
+ SECTION:=devel
|
|
26
|
+ CATEGORY:=Development
|
|
27
|
+ TITLE:=m4
|
|
28
|
+ URL:=https://www.gnu.org/software/m4/
|
|
29
|
+endef
|
|
30
|
+
|
|
31
|
+define Package/m4/description
|
|
32
|
+ GNU M4 is an implementation of the traditional Unix macro processor.
|
|
33
|
+ It is used by GNU Autoconf and Automake.
|
|
34
|
+endef
|
|
35
|
+
|
|
36
|
+define Package/m4/install
|
|
37
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
38
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/m4 $(1)/usr/bin/
|
|
39
|
+endef
|
|
40
|
+
|
|
41
|
+$(eval $(call BuildPackage,m4))
|