Browse Source

esniper: add esniper

Signed-off-by: Thomas Weißschuh <thomas@t-8ch.de>
Thomas Weißschuh 9 years ago
parent
commit
8aa7f2724f
1 changed files with 42 additions and 0 deletions
  1. 42
    0
      net/esniper/Makefile

+ 42
- 0
net/esniper/Makefile View File

@@ -0,0 +1,42 @@
1
+#
2
+# Copyright (C) 2015 Thomas Weißschuh
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=esniper
11
+PKG_VERSION:=2.31.0
12
+PKG_RELEASE:=1
13
+PKG_LICENSE:=BSD-2-Clause
14
+PKG_LICENSE_FILES:=COPYING
15
+PKG_MAINTAINER:=Thomas Weißschuh <openwrt@t-8ch.de>
16
+
17
+VERSION_TRANSFORMED:=$(subst .,-,$(PKG_VERSION))
18
+
19
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(VERSION_TRANSFORMED)
20
+PKG_SOURCE:=$(PKG_NAME)-$(VERSION_TRANSFORMED).tgz
21
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
22
+PKG_MD5SUM:=4b411588c4a223acef7333ab684c7618
23
+
24
+PKG_BUILD_PARALLEL:=1
25
+
26
+include $(INCLUDE_DIR)/package.mk
27
+
28
+define Package/esniper
29
+  SECTION:=net
30
+  CATEGORY:=Network
31
+  TITLE:=Simple, lightweight tool for sniping eBay auctions
32
+  URL:=http://esniper.sourceforge.net/
33
+  DEPENDS:=+libcurl +ca-certificates
34
+endef
35
+
36
+define Package/esniper/install
37
+	$(INSTALL_DIR) $(1)/usr/bin
38
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/esniper $(1)/usr/bin/
39
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/frontends/snipe $(1)/usr/bin/
40
+endef
41
+
42
+$(eval $(call BuildPackage,esniper))