Browse Source

perl: Cleanup

- Update copyright notice
- Make perlbase-experimental's TITLE show up in menuconfig again
- Formatting changes

Signed-off-by: Marcel Denia <naoir@gmx.net>
Marcel Denia 10 years ago
parent
commit
8ab3731392
2 changed files with 5 additions and 4 deletions
  1. 4
    3
      lang/perl/Makefile
  2. 1
    1
      lang/perl/perlbase.mk

+ 4
- 3
lang/perl/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2006-2014 OpenWrt.org
2
+# Copyright (C) 2006-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -40,6 +40,7 @@ ifneq ($(CONFIG_USE_EGLIBC),)
40 40
 	EXTRA_LIBS:=bsd
41 41
 	EXTRA_LIBDIRS:=$(STAGING_DIR)/lib
42 42
 endif
43
+
43 44
 # Filter -g3, it will break Compress-Raw-Zlib
44 45
 TARGET_CFLAGS_PERL:=$(patsubst -g3,-g,$(TARGET_CFLAGS))
45 46
 TARGET_CPPFLAGS_PERL:=$(patsubst -g3,-g,$(TARGET_CPPFLAGS))
@@ -58,11 +59,11 @@ ifdef CONFIG_PERL_THREADS
58 59
 	endif
59 60
 endif
60 61
 
61
-# A list of disabled testss
62
+# A list of disabled tests
62 63
 # ExtUtils tests are disabled for now as we don't support building
63 64
 # native extensions on the target machine at the moment
64 65
 PERL_DISABLEDTESTS:=cpan/ExtUtils-Constant cpan/ExtUtils-MakeMaker
65
-# We're on Linux, so don't even package those
66
+# We're on Linux, so don't even package them
66 67
 PERL_DISABLEDTESTS+=cpan/Win32API-File cpan/Win32 ext/VMS-DCLsym ext/VMS-Filespec ext/VMS-Stdio ext/Win32CORE
67 68
 # NDBM and ODBM not supported
68 69
 PERL_DISABLEDTESTS+=ext/NDBM_File ext/ODBM_File

+ 1
- 1
lang/perl/perlbase.mk View File

@@ -562,7 +562,7 @@ $(eval $(call BuildPackage,perlbase-essential))
562 562
 
563 563
 define Package/perlbase-experimental
564 564
 $(call Package/perlbase-template)
565
-TITLE:=perl module to enable/disable experimental features
565
+TITLE:=experimental perl module
566 566
 DEPENDS+=+perlbase-essential +perlbase-feature
567 567
 endef
568 568