Browse Source

picocom: import and adopt

Signed-off-by: Steven Barth <steven@midlink.org>
Steven Barth 10 years ago
parent
commit
8c9c803128
1 changed files with 46 additions and 0 deletions
  1. 46
    0
      utils/picocom/Makefile

+ 46
- 0
utils/picocom/Makefile View File

@@ -0,0 +1,46 @@
1
+#
2
+# Copyright (C) 2006-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=picocom
11
+PKG_VERSION:=1.7
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=http://picocom.googlecode.com/files
16
+PKG_MD5SUM:=8eaba1d31407e8408674d6e57af447ef
17
+
18
+PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
19
+PKG_LICENSE:=GPL-2.0+
20
+
21
+include $(INCLUDE_DIR)/package.mk
22
+
23
+define Package/picocom
24
+  SECTION:=utils
25
+  CATEGORY:=Utilities
26
+  TITLE:=A minimal dumb-terminal emulation program
27
+  URL:=http://code.google.com/p/picocom/
28
+  SUBMENU:=Terminal
29
+endef
30
+
31
+define Package/picocom/description
32
+ minimal dumb-terminal emulation program
33
+endef
34
+
35
+define Build/Compile
36
+	$(MAKE) -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS) \
37
+		CFLAGS="$(TARGET_CFLAGS)" LDFLAGS="$(TARGET_LDFLAGS)" \
38
+		picocom
39
+endef
40
+
41
+define Package/picocom/install
42
+	$(INSTALL_DIR) $(1)/usr/bin
43
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/picocom $(1)/usr/bin/
44
+endef
45
+
46
+$(eval $(call BuildPackage,picocom))