Browse Source

Update minidlna to 1.1.3 version

medaved 10 years ago
parent
commit
8d9d950235
2 changed files with 92 additions and 1 deletions
  1. 1
    1
      multimedia/minidlna/Makefile
  2. 91
    0
      multimedia/minidlna/Makefile~

+ 1
- 1
multimedia/minidlna/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2010-2013 OpenWrt.org
2
+# Copyright (C) 2010-2014 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.

+ 91
- 0
multimedia/minidlna/Makefile~ View File

@@ -0,0 +1,91 @@
1
+#
2
+# Copyright (C) 2010-2013 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=minidlna
11
+PKG_VERSION:=1.1.3
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=@SF/minidlna
16
+PKG_MD5SUM:=879027192C89E5376CDD2AE2D1AA33B4
17
+
18
+PKG_BUILD_PARALLEL:=0
19
+PKG_BUILD_DEPENDS:=util-linux
20
+
21
+include $(INCLUDE_DIR)/kernel.mk
22
+include $(INCLUDE_DIR)/package.mk
23
+include $(INCLUDE_DIR)/nls.mk
24
+
25
+define Package/minidlna
26
+  SECTION:=multimedia
27
+  CATEGORY:=Multimedia
28
+  TITLE:=UPnP A/V & DLNA Media Server
29
+  URL:=http://minidlna.sourceforge.net/
30
+  DEPENDS:= +libpthread +libexif +libjpeg +libsqlite3 +libffmpeg \
31
+  	+libid3tag +libflac +libvorbis +libuuid \
32
+  	$(ICONV_DEPENDS) $(INTL_DEPENDS)
33
+endef
34
+
35
+define Package/minidlna/description
36
+  MiniDLNA (aka ReadyDLNA) is server software with the aim of
37
+  being fully compliant with DLNA/UPnP-AV clients.
38
+endef
39
+
40
+define Package/minidlna/conffiles
41
+/etc/minidlna.conf
42
+endef
43
+
44
+TARGET_CPPFLAGS += \
45
+	-I$(STAGING_DIR)/usr/include \
46
+	-I$(STAGING_DIR)/usr/include/FLAC \
47
+	-I$(STAGING_DIR)/usr/include/libavcodec \
48
+	-I$(STAGING_DIR)/usr/include/libavformat \
49
+	-I$(STAGING_DIR)/usr/include/libavutil \
50
+	-I$(STAGING_DIR)/usr/include/libexif \
51
+	-I$(STAGING_DIR)/usr/include/uuid \
52
+	-I$(STAGING_DIR)/usr/include/vorbis \
53
+	-I$(ICONV_PREFIX)/include \
54
+	-I$(INTL_PREFIX)/include \
55
+	-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 \
56
+
57
+TARGET_LDFLAGS += \
58
+	-L$(ICONV_PREFIX)/lib \
59
+	-L$(INTL_PREFIX)/lib \
60
+	-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
61
+
62
+MAKE_FLAGS +=\
63
+	CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
64
+	LDFLAGS="$(TARGET_LDFLAGS)" \
65
+	ICONV_LIBS="-liconv $(if $(INTL_FULL),-lintl)" \
66
+
67
+MAKE_VARS +=\
68
+	PREFIX="$(STAGING_DIR)/usr" \
69
+	ICONV_PREFIX="$(ICONV_PREFIX)" \
70
+	INTL_PREFIX="$(INTL_PREFIX)" \
71
+	OS_NAME="OpenWrt Linux" \
72
+	OS_VERSION="$(LINUX_VERSION)" \
73
+	OS_URL="http://openwrt.org/" \
74
+	DB_PATH="/var/run/minidlna" \
75
+	LOG_PATH="/var/log" \
76
+
77
+
78
+define Package/minidlna/install
79
+	$(INSTALL_DIR) $(1)/usr/bin
80
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/minidlna $(1)/usr/bin/
81
+	$(INSTALL_DIR) $(1)/etc/init.d
82
+	$(INSTALL_BIN) ./files/minidlna.init $(1)/etc/init.d/minidlna
83
+	$(INSTALL_DIR) $(1)/etc/config
84
+	$(INSTALL_CONF) ./files/minidlna.config $(1)/etc/config/minidlna
85
+endef
86
+
87
+define Package/minidlna/conffiles
88
+/etc/config/minidlna
89
+endef
90
+
91
+$(eval $(call BuildPackage,minidlna))