Browse Source

Merge pull request #2012 from commodo/stress-package

stress: bring it back (from old packages)
Ted Hess 9 years ago
parent
commit
906c32a5b6
1 changed files with 49 additions and 0 deletions
  1. 49
    0
      utils/stress/Makefile

+ 49
- 0
utils/stress/Makefile View File

@@ -0,0 +1,49 @@
1
+#
2
+# Copyright (C) 2006-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=stress
11
+PKG_VERSION:=1.0.4
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=http://people.seas.harvard.edu/~apw/stress/
16
+PKG_MD5SUM:=a607afa695a511765b40993a64c6e2f4
17
+
18
+PKG_LICENSE:=GPL-2.0
19
+PKG_LICENSE_FILES:=COPYING
20
+
21
+PKG_INSTALL:=1
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+
25
+define Package/stress
26
+  SECTION:=utils
27
+  CATEGORY:=Utilities
28
+  TITLE:=stress is a simple stress utility
29
+  URL:=http://people.seas.harvard.edu/~apw/stress/
30
+  MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
31
+endef
32
+
33
+define Package/stress/description
34
+stress is a simple tool that imposes certain types of compute \ stress on
35
+UNIX-like operating systems.
36
+endef
37
+
38
+CONFIGURE_ARGS += \
39
+	--prefix="/usr"
40
+
41
+MAKE_FLAGS += \
42
+	CFLAGS="$(TARGET_CFLAGS)"
43
+
44
+define Package/stress/install
45
+	$(INSTALL_DIR) $(1)/usr/bin
46
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/stress $(1)/usr/bin/
47
+endef
48
+
49
+$(eval $(call BuildPackage,stress))