Selaa lähdekoodia

shairport-sync: update to 2.8.2

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Álvaro Fernández Rojas 8 vuotta sitten
vanhempi
commit
90e88da723

+ 1
- 1
sound/shairport-sync/Makefile Näytä tiedosto

@@ -9,7 +9,7 @@
9 9
 include $(TOPDIR)/rules.mk
10 10
 
11 11
 PKG_NAME:=shairport-sync
12
-PKG_VERSION:=2.8.1
12
+PKG_VERSION:=2.8.2
13 13
 PKG_RELEASE:=1
14 14
 
15 15
 PKG_SOURCE_PROTO:=git

+ 7
- 5
sound/shairport-sync/files/shairport-sync.config Näytä tiedosto

@@ -24,11 +24,7 @@ config shairport-sync 'shairport_sync'
24 24
 	option log_verbosity '' # 0/1/2/3
25 25
 	option ignore_volume_control '' # no/yes
26 26
 	option volume_range_db '' # 30 to 150
27
-	# Latencies
28
-	option latencies_default '' # 88200
29
-	option latencies_itunes '' # 99400
30
-	option latencies_airplay '' # 88200
31
-	option latencies_forked_daapd '' # 99400
27
+	option regtype '' # _raop._tcp
32 28
 	# Metadata
33 29
 	option metadata_enabled '' # no/yes
34 30
 	option metadata_cover_art '' # no/yes
@@ -45,6 +41,9 @@ config shairport-sync 'shairport_sync'
45 41
 	option alsa_mixer_device '' # default
46 42
 	option alsa_latency_offset '' # 0
47 43
 	option alsa_buffer_length '' # 6615
44
+	option alsa_disable_synchronization '' # no/yes
45
+	option alsa_period_size '' # number
46
+	option alsa_buffer_size '' # number
48 47
 	# Pipe
49 48
 	option pipe_name '' # /tmp/shairport-sync-audio
50 49
 	option pipe_latency_offset '' # 0
@@ -52,3 +51,6 @@ config shairport-sync 'shairport_sync'
52 51
 	# Stdout
53 52
 	option stdout_latency_offset '' # 0
54 53
 	option stdout_buffer_length '' # 44100
54
+	# AO
55
+	option ao_latency_offset '' # 0
56
+	option ao_buffer_length '' # 44100

+ 12
- 10
sound/shairport-sync/files/shairport-sync.init Näytä tiedosto

@@ -1,5 +1,5 @@
1 1
 #!/bin/sh /etc/rc.common
2
-# Copyright (C) 2015 OpenWrt.org
2
+# Copyright (C) 2015-2016 OpenWrt.org
3 3
 
4 4
 START=99
5 5
 USE_PROCD=1
@@ -59,15 +59,7 @@ start_instance() {
59 59
 		append_num "$cfg" "$conf_file" log_verbosity "log_verbosity"
60 60
 		append_str "$cfg" "$conf_file" ignore_volume_control "ignore_volume_control"
61 61
 		append_num "$cfg" "$conf_file" volume_range_db "volume_range_db"
62
-		echo -e "};\n" >> $conf_file
63
-
64
-		# Latencies
65
-		echo -e "latencies =" >> $conf_file
66
-		echo -e "{" >> $conf_file
67
-		append_num "$cfg" "$conf_file" latencies_default "default"
68
-		append_num "$cfg" "$conf_file" latencies_itunes "itunes"
69
-		append_num "$cfg" "$conf_file" latencies_airplay "airplay"
70
-		append_num "$cfg" "$conf_file" latencies_forked_daapd "forkedDaapd"
62
+		append_str "$cfg" "$conf_file" regtype "regtype"
71 63
 		echo -e "};\n" >> $conf_file
72 64
 
73 65
 		# Metadata
@@ -96,6 +88,9 @@ start_instance() {
96 88
 		append_str "$cfg" "$conf_file" alsa_mixer_device "mixer_device"
97 89
 		append_num "$cfg" "$conf_file" alsa_latency_offset "audio_backend_latency_offset"
98 90
 		append_num "$cfg" "$conf_file" alsa_buffer_length "audio_backend_buffer_desired_length"
91
+		append_str "$cfg" "$conf_file" alsa_disable_synchronization "disable_synchronization"
92
+		append_num "$cfg" "$conf_file" alsa_period_size "period_size"
93
+		append_num "$cfg" "$conf_file" alsa_buffer_size "buffer_size"
99 94
 		echo -e "};\n" >> $conf_file
100 95
 
101 96
 		# Pipe audio back end
@@ -112,6 +107,13 @@ start_instance() {
112 107
 		append_num "$cfg" "$conf_file" stdout_latency_offset "audio_backend_latency_offset"
113 108
 		append_num "$cfg" "$conf_file" stdout_buffer_length "audio_backend_buffer_desired_length"
114 109
 		echo -e "};\n" >> $conf_file
110
+
111
+		# AO audio back end
112
+		echo -e "ao =" >> $conf_file
113
+		echo -e "{" >> $conf_file
114
+		append_num "$cfg" "$conf_file" ao_latency_offset "audio_backend_latency_offset"
115
+		append_num "$cfg" "$conf_file" ao_buffer_length "audio_backend_buffer_desired_length"
116
+		echo -e "};\n" >> $conf_file
115 117
 	fi
116 118
 
117 119
 	procd_open_instance