Преглед изворни кода

Import ccid

bump version to 1.4.17 and add myself as maintainer.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Daniel Golle пре 10 година
родитељ
комит
919bc161e6
1 измењених фајлова са 50 додато и 0 уклоњено
  1. 50
    0
      utils/ccid/Makefile

+ 50
- 0
utils/ccid/Makefile Прегледај датотеку

@@ -0,0 +1,50 @@
1
+#
2
+# Copyright (C) 2009-2012 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=ccid
11
+PKG_VERSION:=1.4.17
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15
+PKG_SOURCE_URL:=https://alioth.debian.org/frs/download.php/file/4091
16
+PKG_MD5SUM:=a227a20a0dd034cd4bb7400806a0a2d0
17
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
18
+
19
+PKG_FIXUP:=libtool
20
+PKG_INSTALL:=1
21
+
22
+include $(INCLUDE_DIR)/package.mk
23
+
24
+define Package/ccid
25
+  SECTION:=libs
26
+  CATEGORY:=Libraries
27
+  DEPENDS:=+libusb-1.0 +libpcsclite
28
+  TITLE:=Generic USB CCID smart card reader driver
29
+  URL:=http://pcsclite.alioth.debian.org/ccid.html
30
+endef
31
+
32
+define Package/ccid/description
33
+  Generic USB CCID (Chip/Smart Card Interface Devices) driver and ICCD
34
+  (Integrated Circuit(s) Card Devices).
35
+endef
36
+
37
+TARGET_CFLAGS += $(FPIC)
38
+
39
+TARGET_LDFLAGS += "-lpthread"
40
+
41
+CONFIGURE_ARGS += \
42
+	--enable-embedded \
43
+	--enable-usbdropdir=/usr/lib/pcsc/drivers
44
+
45
+define Package/ccid/install
46
+	$(INSTALL_DIR) $(1)/usr/lib/pcsc
47
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pcsc/drivers $(1)/usr/lib/pcsc/
48
+endef
49
+
50
+$(eval $(call BuildPackage,ccid))