瀏覽代碼

hamlib: avoid build failures with spurious libraries

* always use libusb >= 1.0 (avoid pulling libusb-compat)
* never use libxml2

Signed-off-by: Steven Barth <steven@midlink.org>
Steven Barth 10 年之前
父節點
當前提交
9322b39614
共有 2 個文件被更改,包括 31 次插入1 次删除
  1. 1
    1
      utils/hamlib/Makefile
  2. 30
    0
      utils/hamlib/patches/100-override-autoconf-detection.patch

+ 1
- 1
utils/hamlib/Makefile 查看文件

@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
8 8
 
9 9
 PKG_NAME:=hamlib
10 10
 PKG_VERSION:=1.2.15.3
11
-PKG_RELEASE:=1
11
+PKG_RELEASE:=2
12 12
 PKG_MD5SUM:=3cad8987e995a00e5e9d360e2be0eb43
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz

+ 30
- 0
utils/hamlib/patches/100-override-autoconf-detection.patch 查看文件

@@ -0,0 +1,30 @@
1
+Index: hamlib-1.2.15.3/configure.ac
2
+===================================================================
3
+--- hamlib-1.2.15.3.orig/configure.ac	2012-11-01 22:27:27.000000000 +0100
4
++++ hamlib-1.2.15.3/configure.ac	2014-06-15 09:34:25.557966205 +0200
5
+@@ -234,12 +234,12 @@
6
+ 		"You need a C99 compliant C compiler that supports struct/array intializers."
7
+ 		"Have you considered GCC lately?.")]);
8
+ 
9
+-dnl libxml2 required rigmem xml support
10
+-PKG_CHECK_MODULES([LIBXML2], [libxml-2.0],
11
+-	[AC_DEFINE(HAVE_XML2,[1],[Define if libxml2 is available])],
12
+-	[AC_MSG_WARN([libxml-2.0 pkg-config not found, XML support will be disabled])])
13
++#dnl libxml2 required rigmem xml support
14
++#PKG_CHECK_MODULES([LIBXML2], [libxml-2.0],
15
++#	[AC_DEFINE(HAVE_XML2,[1],[Define if libxml2 is available])],
16
++#	[AC_MSG_WARN([libxml-2.0 pkg-config not found, XML support will be disabled])])
17
+ AC_SUBST(LIBXML2_LIBS)
18
+ AC_SUBST(LIBXML2_CFLAGS)
19
+ 
20
+ dnl Check if libgd-dev is installed, so we can enable rigmatrix
21
+ 
22
+@@ -406,7 +406,7 @@
23
+ AM_CONDITIONAL(HAVE_USRP, test x"${cf_with_usrp}" = "xyes")
24
+ 
25
+ 
26
+-PKG_CHECK_MODULES(LIBUSB, libusb >= 0.1, ,
27
++PKG_CHECK_MODULES(LIBUSB, libusb >= 1.0, ,
28
+ 		  [AC_MSG_WARN([libusb pkg-config not found, USB backends will be disabled])])
29
+ CFLAGS="${CFLAGS} ${LIBUSB_CFLAGS}"
30
+ CXXFLAGS="${CXXFLAGS} ${LIBUSB_CFLAGS}"