Parcourir la source

ctorrent: fix musl compatibility

Add missing `sys/types.h` include to `strnstr()` replacement code in
`compat.c` in order to declare `ssize_t` type under musl.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Jo-Philipp Wich il y a 9 ans
Parent
révision
93b1d74c76
2 fichiers modifiés avec 12 ajouts et 2 suppressions
  1. 2
    2
      net/ctorrent/Makefile
  2. 10
    0
      net/ctorrent/patches/200-musl-compat.patch

+ 2
- 2
net/ctorrent/Makefile Voir le fichier

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2006-2008 OpenWrt.org
2
+# Copyright (C) 2006-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=ctorrent
11 11
 PKG_VERSION:=dnh3.3.2
12
-PKG_RELEASE:=6
12
+PKG_RELEASE:=7
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=@SF/dtorrent \

+ 10
- 0
net/ctorrent/patches/200-musl-compat.patch Voir le fichier

@@ -0,0 +1,10 @@
1
+--- a/compat.c
2
++++ b/compat.c
3
+@@ -63,6 +63,7 @@ int snprintf(char *str, size_t size, con
4
+ 
5
+ #ifndef HAVE_STRNSTR
6
+ #include <string.h>
7
++#include <sys/types.h>
8
+ /* FUNCTION PROGRAMER: Siberiaic Sang */
9
+ char *strnstr(const char *haystack, const char *needle, size_t haystacklen)
10
+ {